aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-distro/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-distro/APKBUILD')
-rw-r--r--community/py3-distro/APKBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/community/py3-distro/APKBUILD b/community/py3-distro/APKBUILD
index c37b7ee9e39..6420cbf2380 100644
--- a/community/py3-distro/APKBUILD
+++ b/community/py3-distro/APKBUILD
@@ -1,17 +1,17 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Celeste <cielesti@protonmail.com>
pkgname=py3-distro
_pkgname=distro
-pkgver=1.7.0
-pkgrel=0
+pkgver=1.9.0
+pkgrel=2
pkgdesc="A Linux OS platform information API"
options="!check" # Some tests fail
-url="https://github.com/nir0s/distro"
+url="https://github.com/python-distro/distro"
arch="noarch"
license="Apache-2.0"
-depends="python3"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
checkdepends="py3-pytest py3-pytest-cov"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -19,7 +19,9 @@ replaces=py-distro # Backwards compatibility
provides=py-distro=$pkgver-r$pkgrel # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
@@ -27,9 +29,10 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/distro-*.whl
}
sha512sums="
-14516ecab33ee8c57c35a8279eb515fd699031fabac7d8886092ea98696797d55503179870aeb513a85e1a66c7e69f2f60bb6ea9fc935be975cb5135e1917ecc distro-1.7.0.tar.gz
+dc66cb7e968e7a651c7a84681e2a0539d196073f71cf0ae1e49c5a6cd6deec345523259a8810ffdc7b6e9763a536eb388a2886ba2bbd1cb62165b57fbefb82ae distro-1.9.0.tar.gz
"