aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-django-crispy-forms
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-django-crispy-forms')
-rw-r--r--community/py3-django-crispy-forms/APKBUILD30
1 files changed, 22 insertions, 8 deletions
diff --git a/community/py3-django-crispy-forms/APKBUILD b/community/py3-django-crispy-forms/APKBUILD
index 7b0760ef876..12924696d83 100644
--- a/community/py3-django-crispy-forms/APKBUILD
+++ b/community/py3-django-crispy-forms/APKBUILD
@@ -1,15 +1,21 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
-# Maintainer: Justin Berthault <justin.berthault@zaclys.net>
+# Contributor: Justin Berthault <justin.berthault@zaclys.net>
+# Maintainer:
pkgname=py3-django-crispy-forms
-pkgver=1.13.0
-pkgrel=0
+pkgver=2.1
+pkgrel=1
pkgdesc="Dry Django forms"
options="!check" # No testsuite
url="https://github.com/django-crispy-forms/django-crispy-forms"
arch="noarch"
license="MIT"
depends="py3-django"
-makedepends="py3-setuptools"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/d/django-crispy-forms/django-crispy-forms-$pkgver.tar.gz"
builddir="$srcdir"/django-crispy-forms-$pkgver
@@ -17,14 +23,22 @@ replaces="py-django-crispy-forms" # Backwards compatibility
provides="py-django-crispy-forms=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py --quiet build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 runtests.py
}
package() {
- python3 setup.py --quiet install --prefix=/usr --root="$pkgdir"
- rm -rf "$pkgdir"/usr/lib/python3*/site-packages/crispy_forms/tests
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-a52709470df3e4f32671cfa488135cea8947f726f6874bc2943f4c4f132c08d01fb6bc18a1b78e2756e381815d80c140c5e99c4db8ea1dffe7943b0ed1c03ecf py3-django-crispy-forms-1.13.0.tar.gz
+35ef471cc9eda6a2f84b050c19795d2551490bd393f57ac2c0f8d5731b2f1cc135db2cfe948898e3014799afe5b9c107061b71de3c1651d6f0af66fc8d9ea4ac py3-django-crispy-forms-2.1.tar.gz
"