aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-django-model-utils/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-django-model-utils/APKBUILD')
-rw-r--r--community/py3-django-model-utils/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/community/py3-django-model-utils/APKBUILD b/community/py3-django-model-utils/APKBUILD
new file mode 100644
index 00000000000..bc6922aed70
--- /dev/null
+++ b/community/py3-django-model-utils/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Alex Denes <caskd@redxen.eu>
+# Maintainer: Alex Denes <caskd@redxen.eu>
+_pkgname=django-model-utils
+pkgname="py3-$_pkgname"
+pkgver=4.4.0
+pkgrel=1
+pkgdesc="Django model mixins and utilities"
+url="https://github.com/jazzband/django-model-utils"
+arch="noarch"
+license="BSD-3-Clause"
+depends="
+ py3-django
+"
+makedepends="py3-setuptools_scm"
+checkdepends="
+ py3-pytest
+ py3-pytest-django
+ py3-psycopg2
+ py3-pytest-cov
+"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+options="!check" # requires py3-pytest-django
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --root "$pkgdir"
+}
+
+sha512sums="
+c912b45712ae4ea1b8a4d683f9954956e1fb5a56b1f5ddf8840c895e3f10c4cf4927d833ef14480a2d1021e5a220a8d1fb588ff6c944481a429e1305da58bab8 django-model-utils-4.4.0.tar.gz
+"