aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-django-pipeline/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-django-pipeline/APKBUILD')
-rw-r--r--community/py3-django-pipeline/APKBUILD30
1 files changed, 23 insertions, 7 deletions
diff --git a/community/py3-django-pipeline/APKBUILD b/community/py3-django-pipeline/APKBUILD
index 960b374489c..4adb2a63d81 100644
--- a/community/py3-django-pipeline/APKBUILD
+++ b/community/py3-django-pipeline/APKBUILD
@@ -1,25 +1,41 @@
# Contributor: <xmingske@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py3-django-pipeline
-pkgver=1.7.0
+pkgver=3.0.0
pkgrel=1
pkgdesc="an asset packaging library for Django"
options="!check" # Can't run tests
-url="https://github.com/cyberdelia/django-pipeline"
+url="https://github.com/jazzband/django-pipeline"
arch="noarch"
license="JSON"
depends="python3"
-makedepends="py3-setuptools"
+makedepends="
+ py3-gpep517
+ py3-setuptools_scm
+ py3-wheel
+ "
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/d/django-pipeline/django-pipeline-$pkgver.tar.gz"
-
builddir="$srcdir/django-pipeline-$pkgver"
build() {
- python3 setup.py build
+ SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver \
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 runtests.py
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="08a85c890571decc1f26a9ae22cba307782d8a41bbe9a23ac799590cfa37f9ef920eeeeb0665e35928e2f09f48fcdcac3d4b6435e22388ffbd2c244b81d8d672 django-pipeline-1.7.0.tar.gz"
+sha512sums="
+e4d33810d085ab028218a1f042d7b50157d40cf61f31aca8861db59d5ce471da6c8b5f2f46e4096b6c406e860a64141d8abf4df627322bc53129b0de0d47d56c django-pipeline-3.0.0.tar.gz
+"