aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-django-registration/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-django-registration/APKBUILD')
-rw-r--r--community/py3-django-registration/APKBUILD25
1 files changed, 17 insertions, 8 deletions
diff --git a/community/py3-django-registration/APKBUILD b/community/py3-django-registration/APKBUILD
index d2cde41d0cc..cc003337539 100644
--- a/community/py3-django-registration/APKBUILD
+++ b/community/py3-django-registration/APKBUILD
@@ -2,28 +2,37 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py3-django-registration
_pyname=django-registration
-pkgver=3.1
+pkgver=3.4
pkgrel=1
pkgdesc="simple user-registration application for Django"
url="https://github.com/ubernostrum/django-registration"
arch="noarch"
license="BSD-3-Clause"
-depends="python3"
-makedepends="py3-setuptools"
+depends="py3-django"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="$_pyname-$pkgver.tar.gz::https://github.com/ubernostrum/django-registration/archive/$pkgver.tar.gz"
-
builddir="$srcdir/$_pyname-$pkgver"
+options="!check" # need setup
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py check
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="86764b317ab6d841028f19abc03cd76fb571a88a3073c6aad4de2d0b186b9a2b6a5b5f16b66530997b26adca704b0594619cf31ed1a2eb757c81e6913f62f2b9 django-registration-3.1.tar.gz"
+sha512sums="
+b6c87cbaeb9548e2c2d8672078b5967aee1e881c2b880193ba410a8c293c93fd0c8e57abac8deda2cb6f61a11936fd5c72060e4954f1d74de1e3a3646b63885b django-registration-3.4.tar.gz
+"