aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-django-rest-framework/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-django-rest-framework/APKBUILD')
-rw-r--r--community/py3-django-rest-framework/APKBUILD27
1 files changed, 18 insertions, 9 deletions
diff --git a/community/py3-django-rest-framework/APKBUILD b/community/py3-django-rest-framework/APKBUILD
index fe21336e404..691741a3f4d 100644
--- a/community/py3-django-rest-framework/APKBUILD
+++ b/community/py3-django-rest-framework/APKBUILD
@@ -1,30 +1,39 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
-# Maintainer: Justin Berthault <justin.berthault@zaclys.net>
+# Contributor: Justin Berthault <justin.berthault@zaclys.net>
+# Maintainer: Antoine Martin (ayakael) <dev@ayakael.net>
pkgname=py3-django-rest-framework
_pkgname=django-rest-framework
-pkgver=3.12.4
+pkgver=3.15.1
pkgrel=1
pkgdesc="Web APIs for Django"
options="!check" # fails with "OperationalError: no such table: auth_user"
url="https://github.com/encode/django-rest-framework"
arch="noarch"
license="Custom"
-depends="py3-django"
-makedepends="py3-setuptools"
-checkdepends="py3-pytest py3-tz py3-core-api py3-jinja2 py3-uritemplate"
+depends="py3-django py3-tz"
+makedepends="py3-setuptools py3-gpep517 py3-wheel"
+checkdepends="py3-pytest py3-core-api py3-jinja2 py3-uritemplate"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/encode/$_pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
- python3 setup.py --quiet build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 runtests.py
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer "$builddir"/.dist/*.whl
+ .testenv/bin/python3 ./runtests.py
}
package() {
- python3 setup.py --quiet install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="406b5354809b94e371a2c7d4b62ce66c18a1f60bd02574cba603ad4c44faa4297bdbbd6ee50de63fe21d2aae18386e05d46983a506bddd17f06ce610d5b727c9 py3-django-rest-framework-3.12.4.tar.gz"
+sha512sums="
+e44c3d861973928194035364fb6b5ddffbcacab959072b2c549971dd6675b5a5f1be13b55856154dbffaefb48dcbd4a63fd9ffbce5456507b52fd5e4648706b9 py3-django-rest-framework-3.15.1.tar.gz
+"