aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-dns-lexicon/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-dns-lexicon/APKBUILD')
-rw-r--r--community/py3-dns-lexicon/APKBUILD49
1 files changed, 30 insertions, 19 deletions
diff --git a/community/py3-dns-lexicon/APKBUILD b/community/py3-dns-lexicon/APKBUILD
index 527b2600c0a..ce46ca80da3 100644
--- a/community/py3-dns-lexicon/APKBUILD
+++ b/community/py3-dns-lexicon/APKBUILD
@@ -1,56 +1,67 @@
# Contributor: Duncan Bellamy <dunk@denkimushi.com>
# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
pkgname=py3-dns-lexicon
-pkgver=3.6.1
-pkgrel=0
+pkgver=3.17.0
+pkgrel=1
pkgdesc="Manipulate DNS records on various DNS providers in a standardized/agnostic way"
-options="!check" # Tests require GitHub tarball which has broken setup.py
url="https://github.com/AnalogJ/lexicon"
arch="noarch"
license="MIT"
+#tests need net access
+options="net"
depends="
- py3-tldextract
+ py3-beautifulsoup4
+ py3-cryptography
+ py3-dnspython
+ py3-future
+ py3-otp
py3-requests
+ py3-tldextract
py3-yaml
- py3-future
- py3-cryptography
- py3-beautifulsoup4
"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-poetry-core"
_providerdepends="
py3-boto3
- py3-pynamecheap
- py3-transip
- py3-xmltodict
py3-localzone
+ py3-oci
py3-softlayer
- py3-zeep
+ py3-softlayer-zeep
+ py3-xmltodict
"
checkdepends="
py3-filelock
py3-pytest
py3-pytest-mock
+ py3-pytest-xdist
py3-requests-file
py3-vcrpy
$_providerdepends
"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/d/dns-lexicon/dns-lexicon-$pkgver.tar.gz"
-builddir="$srcdir/dns-lexicon-$pkgver"
+subpackages="$pkgname-pyc"
+source="$pkgname-github-$pkgver.tar.gz::https://github.com/AnalogJ/lexicon/archive/refs/tags/v$pkgver.tar.gz"
+builddir="$srcdir/lexicon-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ # auto and namecheap tests fail in rootbld
+ .testenv/bin/python3 -m pytest \
+ --ignore tests/providers/test_localzone.py \
+ --ignore tests/providers/test_auto.py \
+ --ignore tests/providers/test_namecheap.py
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-
+ python3 -m installer -d "$pkgdir" .dist/*.whl
rm -rf "$pkgdir"/usr/lib/python3*/site-packages/lexicon/tests
}
sha512sums="
-f142863e90c1dc260bfa9818c5b29d1db2d06f21f4f8fdfbfe9d209a8c0fb1975061650e725309cc0c32f31bb0bf2f8efe75ea30381c47e25cecf2b97887362a py3-dns-lexicon-3.6.1.tar.gz
+1bc182f5881d6acfac72b84331ba50da1219178d274c92e532ed11e73aa79696681d28a002cd1e23f48590953f48e50b62c2ef2db020a07ecf88547717508c0c py3-dns-lexicon-github-3.17.0.tar.gz
"