aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-dns-lexicon/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-dns-lexicon/APKBUILD')
-rw-r--r--community/py3-dns-lexicon/APKBUILD37
1 files changed, 23 insertions, 14 deletions
diff --git a/community/py3-dns-lexicon/APKBUILD b/community/py3-dns-lexicon/APKBUILD
index 5ca951d807f..b5bd2fca195 100644
--- a/community/py3-dns-lexicon/APKBUILD
+++ b/community/py3-dns-lexicon/APKBUILD
@@ -1,58 +1,67 @@
# Contributor: Duncan Bellamy <dunk@denkimushi.com>
# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
pkgname=py3-dns-lexicon
-pkgver=3.11.3
-pkgrel=0
+pkgver=3.17.0
+pkgrel=2
pkgdesc="Manipulate DNS records on various DNS providers in a standardized/agnostic way"
url="https://github.com/AnalogJ/lexicon"
arch="noarch"
license="MIT"
+#tests need net access
+options="net"
depends="
py3-beautifulsoup4
py3-cryptography
+ py3-dnspython
py3-future
+ py3-otp
py3-requests
py3-tldextract
py3-yaml
"
-makedepends="py3-build py3-installer py3-setuptools py3-poetry-core"
+makedepends="py3-gpep517 py3-poetry-core"
_providerdepends="
py3-boto3
py3-localzone
py3-oci
py3-softlayer
+ py3-softlayer-zeep
py3-xmltodict
- py3-zeep
"
checkdepends="
py3-filelock
py3-pytest
py3-pytest-mock
+ py3-pytest-xdist
py3-requests-file
py3-vcrpy
$_providerdepends
"
-source="$pkgname-github-$pkgver.zip::https://github.com/AnalogJ/lexicon/archive/refs/tags/v$pkgver.zip"
+subpackages="$pkgname-pyc"
+source="$pkgname-github-$pkgver.tar.gz::https://github.com/AnalogJ/lexicon/archive/refs/tags/v$pkgver.tar.gz"
builddir="$srcdir/lexicon-$pkgver"
build() {
- # XXX: hack for poetry to not ignore files
- GIT_DIR=. python3 -m build --no-isolation --wheel
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 -m installer -d testenv \
- dist/dns_lexicon-$pkgver-py3-none-any.whl
- local sitedir="$(python3 -c 'import site;print(site.getsitepackages()[0])')"
- PYTHONPATH="$PWD/testenv/$sitedir" python3 -m pytest --ignore lexicon/tests/providers/test_localzone.py lexicon
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ # auto and namecheap tests fail in rootbld
+ .testenv/bin/python3 -m pytest \
+ --ignore tests/providers/test_localzone.py \
+ --ignore tests/providers/test_auto.py \
+ --ignore tests/providers/test_namecheap.py
}
package() {
- python3 -m installer -d "$pkgdir" \
- dist/dns_lexicon-$pkgver-py3-none-any.whl
+ python3 -m installer -d "$pkgdir" .dist/*.whl
rm -rf "$pkgdir"/usr/lib/python3*/site-packages/lexicon/tests
}
sha512sums="
-ead1bbf093a369b9ddc1deb2be0bbc114daeaf88a4ccb54f1a198e2baee30e3c4d46e793a4fd68de47bd5ef609852367570fb2357172bf59355ed2bb1ac2b901 py3-dns-lexicon-github-3.11.3.zip
+1bc182f5881d6acfac72b84331ba50da1219178d274c92e532ed11e73aa79696681d28a002cd1e23f48590953f48e50b62c2ef2db020a07ecf88547717508c0c py3-dns-lexicon-github-3.17.0.tar.gz
"