aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-dnsrobocert/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-dnsrobocert/APKBUILD')
-rw-r--r--community/py3-dnsrobocert/APKBUILD34
1 files changed, 20 insertions, 14 deletions
diff --git a/community/py3-dnsrobocert/APKBUILD b/community/py3-dnsrobocert/APKBUILD
index f23208dda26..c5f0be9570e 100644
--- a/community/py3-dnsrobocert/APKBUILD
+++ b/community/py3-dnsrobocert/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Duncan Bellamy <dunk@denkimushi.com>
# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
pkgname=py3-dnsrobocert
-pkgver=3.20.1
-pkgrel=0
+pkgver=3.25.0
+pkgrel=1
pkgdesc="A tool to manage your DNS-challenged TLS certificates"
url="https://dnsrobocert.readthedocs.io/en/latest/"
arch="noarch"
@@ -24,40 +24,46 @@ depends="
py3-pem
py3-schedule
py3-softlayer
+ py3-softlayer-zeep
py3-tldextract
py3-xmltodict
py3-yaml
- py3-zeep
"
makedepends="
- py3-build
- py3-installer
+ py3-gpep517
py3-poetry-core
"
checkdepends="pebble py3-pytest"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/adferrand/dnsrobocert/archive/v$pkgver.tar.gz
pebble.patch
+ revert-old-python.patch
"
builddir="$srcdir/dnsrobocert-$pkgver"
+case "$CARCH" in
+# blocked by pebble
+riscv64) options="$options !check" ;;
+esac
+
build() {
- # XXX: hack for poetry to not ignore files
- GIT_DIR=. python3 -m build --no-isolation --wheel
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 -m installer -d testenv \
- dist/dnsrobocert-$pkgver-py3-none-any.whl
- local sitedir="$(python3 -c 'import site;print(site.getsitepackages()[0])')"
- PYTHONPATH="$PWD/testenv/$sitedir" python3 -m pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -k 'not test_pfx'
}
package() {
- python3 -m installer -d "$pkgdir" \
- dist/dnsrobocert-$pkgver-py3-none-any.whl
+ python3 -m installer -d "$pkgdir" .dist/*.whl
}
sha512sums="
-6c987772b67a6a9f56b1410b2d79c59b11f1be62f6d00e5dd5ed6ee14afe232d7e1b69b0d43722cb704ed22bca43458612692fa87997b0dceafa1bca5b12e177 py3-dnsrobocert-3.20.1.tar.gz
+bd0998bc5de09bb79c4810d555aa74c40ac497e72f6d40dec64d1472d08a085dc4ce99ec39fa8580a96cb2c1af7bbf88cebc18baba2b4697220d4d72f2cdabe1 py3-dnsrobocert-3.25.0.tar.gz
3a8f2d9a74a35aea2e5eebcede656d2861382c975dc94560eca4f94cd8b13f1bb4a98b5b667cb5937ef9123a8f1da20dcef58a8ffc903e93e979d928bca9f9b1 pebble.patch
+bcaf7e5eccad8a713577269e2458502a089ff59c949c4ea583da6b13d6504f5ad9f905fdf1b0d30c759aa7a1555abcf16cedc11869f6ffef71b09a0204364493 revert-old-python.patch
"