aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-dotmap/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-dotmap/APKBUILD')
-rw-r--r--community/py3-dotmap/APKBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/community/py3-dotmap/APKBUILD b/community/py3-dotmap/APKBUILD
index ebb3926d28a..aa791c6973d 100644
--- a/community/py3-dotmap/APKBUILD
+++ b/community/py3-dotmap/APKBUILD
@@ -2,20 +2,23 @@
# Maintainer: Iztok Fister, Jr. <iztok@iztok-jr-fister.eu>
pkgname=py3-dotmap
_pkgorig=dotmap
-pkgver=1.3.27
-pkgrel=0
+pkgver=1.3.30
+pkgrel=4
pkgdesc="Dot access dictionary with dynamic hierarchy creation and ordered iteration"
url="https://github.com/drgrib/dotmap"
arch="noarch"
license="MIT"
depends="python3"
-makedepends="py3-setuptools"
-checkdepends="py3-pytest"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+checkdepends="py3-pytest-xdist"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/d/dotmap/dotmap-$pkgver.tar.gz"
builddir="$srcdir/$_pkgorig-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
@@ -23,9 +26,10 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-561a0a5a27791124f110655e437de865bc6cd15d2bc2aba3c6695e0c91dbc60e1612b8ae01ba06f24c272580df213a3d19a70ee7d89f5f27225cce0c3f800fc7 py3-dotmap-1.3.27.tar.gz
+8e6d3e4419c3dbd1c0a3209dfc7bcda859bf547ab3fe88471c04a7f4c34219c9ca13b848788e6a24c6d3ece539f9ba0a16600f7941abdbd99c4e6d0badf4af27 py3-dotmap-1.3.30.tar.gz
"