aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-dulwich/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-dulwich/APKBUILD')
-rw-r--r--community/py3-dulwich/APKBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/community/py3-dulwich/APKBUILD b/community/py3-dulwich/APKBUILD
index 8c521b40eea..e53f0d4f060 100644
--- a/community/py3-dulwich/APKBUILD
+++ b/community/py3-dulwich/APKBUILD
@@ -2,16 +2,17 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-dulwich
_pkgname=dulwich
-pkgver=0.20.38
-pkgrel=0
+pkgver=0.21.7
+pkgrel=1
pkgdesc="python implementation of the Git file formats and protocols"
url="https://www.dulwich.io/"
arch="all"
license="GPL-2.0-or-later OR Apache-2.0"
depends="py3-certifi py3-urllib3"
-makedepends="py3-setuptools python3-dev"
+makedepends="py3-setuptools python3-dev py3-gpep517 py3-wheel"
checkdepends="py3-mock py3-gpgme"
-source="https://github.com/dulwich/dulwich/archive/$_pkgname-$pkgver.tar.gz
+subpackages="$pkgname-pyc"
+source="https://github.com/jelmer/dulwich/archive/$_pkgname-$pkgver.tar.gz
skip-network-tests.patch
"
builddir="$srcdir"/$_pkgname-dulwich-$pkgver
@@ -20,18 +21,24 @@ replaces="py-dulwich" # Backwards compatibility
provides="py-dulwich=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 -m unittest dulwich.tests.test_suite
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m unittest dulwich.tests.test_suite
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+ rm -r "$pkgdir"/usr/lib/python3*/site-packages/dulwich/tests/
}
sha512sums="
-9e0df75b1ce62f66497ed4b1f3a36c39d6efd815ba17f5b3c050340a972414565fd049ac8df1dc99470bf0743945eb375f6b466577792adad078a565b16bf02b dulwich-0.20.38.tar.gz
+507705dd4db780a5c91101505d4c02c701579ebccf15a31049cf9b9c1ea333add8429302ac39b99fe33ec0ea7e0eb44008393a7769084221b4c1b169edd953e0 dulwich-0.21.7.tar.gz
23743222a8306518c855b1f9bfd56e8b09624af4199541c1377a9dea5863f4489133e346b181f4018a64402d45a82ada42130ac1bdfa9163e7ff6586df7e3931 skip-network-tests.patch
"