aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-ecdsa/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-ecdsa/APKBUILD')
-rw-r--r--community/py3-ecdsa/APKBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/community/py3-ecdsa/APKBUILD b/community/py3-ecdsa/APKBUILD
index f5601e54271..3aabc457417 100644
--- a/community/py3-ecdsa/APKBUILD
+++ b/community/py3-ecdsa/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-ecdsa
_pkgname=ecdsa
-pkgver=0.16.1
-pkgrel=0
+pkgver=0.18.0
+pkgrel=4
pkgdesc="Python3 cryptographic signature library"
url="https://github.com/warner/python-ecdsa"
arch="noarch"
@@ -11,17 +11,16 @@ license="MIT"
depends="python3 py3-six"
makedepends="py3-setuptools"
checkdepends="py3-hypothesis py3-pytest"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ $pkgname-fix-tests.patch::https://github.com/tlsfuzzer/python-ecdsa/commit/644412d7a27503fb682e7201c57343f3c43b6640.patch
+ $pkgname-fix-test-warnings.patch::https://github.com/tlsfuzzer/python-ecdsa/commit/50c1fa44f35b9d383ffbc3e045a94419f6c347d1.patch
+ "
builddir="$srcdir/$_pkgname-$pkgver"
replaces="py-ecdsa" # Backwards compatibility
provides="py-ecdsa=$pkgver-r$pkgrel" # Backwards compatibility
-case "$CARCH" in
-# tests make broken endianness assumptions on mips
-mips*) options="!check" ;;
-esac
-
# secfixes:
# 0.13.3-r0:
# - CVE-2019-14859
@@ -36,7 +35,11 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="935416ff25a71b1e6fe442b11e8d2c1463b1652d539274e094112a4847c2c749ff58eb9f5ed108ed5613b7363d3f2b1c07ba3d01af8cfed4e1b4bec407d3f5a6 ecdsa-0.16.1.tar.gz"
+sha512sums="
+f26dbeccd8e6ec832405d419b7244ca97b43a2811513493913a4f2f2fd1d2f453068fe0ba7b90b972f42a0d7b9834212fbd4d4559475cffeb1d80075fa954d78 ecdsa-0.18.0.tar.gz
+c907f0ee0b1eb836a1881b20aba5e2234313fa402aa04c7cf39b316ca0bc360717914a267fd6d11db878f254d4547a645c4388d2dc0678024bbecca6308c344f py3-ecdsa-fix-tests.patch
+93643091fb0d8df09018c03b85e2f33475a255770ed39bcc4e18e333b432af86444b2afb4ca73dc89f6f123b27c2dcc6253dda7b8697138eb2bc71026355ae99 py3-ecdsa-fix-test-warnings.patch
+"