aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-eliot
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-eliot')
-rw-r--r--community/py3-eliot/APKBUILD26
1 files changed, 17 insertions, 9 deletions
diff --git a/community/py3-eliot/APKBUILD b/community/py3-eliot/APKBUILD
index 50407222601..ec49a9a738d 100644
--- a/community/py3-eliot/APKBUILD
+++ b/community/py3-eliot/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer: Leo <thinkabit.ukim@gmail.com>
+# Maintainer:
pkgname=py3-eliot
-pkgver=1.13.0
-pkgrel=0
+pkgver=1.15.0
+pkgrel=2
pkgdesc="Logging system that tells you why it happened"
# Requires unpackaged dask and cffi for testing journald
options="!check"
@@ -11,21 +11,29 @@ arch="noarch"
license="Apache-2.0"
depends="python3 py3-six py3-zope-interface py3-pyrsistent py3-boltons
py3-twisted"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-gpep517 py3-wheel"
checkdepends="py3-hypothesis py3-testtools py3-pytest"
-source="$pkgname-$pkgver.tar.gz::https://github.com/itamarst/eliot/archive/$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver-1.tar.gz::https://github.com/itamarst/eliot/archive/refs/tags/$pkgver.tar.gz"
builddir="$srcdir/eliot-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ gpep517 install-wheel --destdir .testenv --prefix '' .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="ada6d7b6026cc572fc65d32b1263d988f04aa96beaa7784abedd536a9bac512c4fce9c438013680b8e13d5c6c0e5042e48a5ea8297553c8eb6b82f9c4967c367 py3-eliot-1.13.0.tar.gz"
+sha512sums="
+031f5b60bc9ee90ef301ad9c43257bf2a39fa516101883576cb426fc6dc124fbd11e5d9b00b610829f3f2366fd6655af23a373abe8dfc52f59c882740e7cce6a py3-eliot-1.15.0-1.tar.gz
+"