aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-evopreprocess/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-evopreprocess/APKBUILD')
-rw-r--r--community/py3-evopreprocess/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/community/py3-evopreprocess/APKBUILD b/community/py3-evopreprocess/APKBUILD
new file mode 100644
index 00000000000..cd0e886e043
--- /dev/null
+++ b/community/py3-evopreprocess/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Iztok Fister, Jr. <iztok@iztok-jr-fister.eu>
+# Maintainer: Iztok Fister, Jr. <iztok@iztok-jr-fister.eu>
+pkgname=py3-evopreprocess
+pkgver=0.5.0
+pkgrel=4
+pkgdesc="Data Preprocessing with Evolutionary and Nature Inspired Algorithms"
+url="https://github.com/karakatic/EvoPreprocess"
+arch="noarch"
+license="GPL-3.0-or-later"
+depends="
+ python3
+ py3-imbalanced-learn
+ py3-niapy
+ py3-numpy
+ py3-scipy
+ py3-scikit-learn
+ "
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+subpackages="$pkgname-pyc"
+source="https://github.com/karakatic/EvoPreprocess/archive/v$pkgver/evopreprocess-$pkgver.tar.gz
+ remove-tests.patch"
+builddir="$srcdir/EvoPreprocess-$pkgver"
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+# tests are immature; use smoke tests instead
+check() {
+ PYTHONPATH=build/lib python3 -c "from evopreprocess.feature_selection import EvoFeatureSelection"
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+}
+
+sha512sums="
+ca8d23b7431f72bbb24b3b651749937c8773b15e0549b1b986990440ce517d5cf426ec9b7790996e9c685c5bffefa548df3948f6caf2048d7e5396b05d27b5cc evopreprocess-0.5.0.tar.gz
+03ba2a5c600119515c0cb9d73d86a8b3ff140cdb06ef49ca710c97a082a9b98c2da0d16472d1675192d8e68159fd5e82fdaa56467b829e4b68b544488dfbf07b remove-tests.patch
+"