aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-execnet
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-execnet')
-rw-r--r--community/py3-execnet/APKBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/community/py3-execnet/APKBUILD b/community/py3-execnet/APKBUILD
index f10e4430309..6f630b1d661 100644
--- a/community/py3-execnet/APKBUILD
+++ b/community/py3-execnet/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Dmitry Romanenko <dmitry@romanenko.in>
pkgname=py3-execnet
_pkgname=execnet
-pkgver=1.7.1
-pkgrel=1
+pkgver=1.9.0
+pkgrel=3
pkgdesc="execnet: rapid multi-Python deployment"
url="https://github.com/pytest-dev/execnet"
arch="noarch"
@@ -12,7 +12,8 @@ depends="py3-apipkg"
# tests for py-gevent are broken, jython is missing in repo, eventlet is part
# of testing
checkdepends="py3-pytest py3-py"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-setuptools_scm"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -29,7 +30,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="375748c03f8d955bd8fca90d5c6308073c31a978fd7a604257512e0a710f899dec5db8a91d5bb5f16de9b0656e1742da9ab513827a1a065a5125bafcf1e63a70 execnet-1.7.1.tar.gz"
+sha512sums="
+d425e7b6f3708efecb5dfa2c36a837cb55f2c32cf2ec0c1dc11cd1ca6ea614d119d04908b84dd5a3593c87db35e71fee202f843665c853ac3538479f60c83d60 execnet-1.9.0.tar.gz
+"