aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-executing/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-executing/APKBUILD')
-rw-r--r--community/py3-executing/APKBUILD26
1 files changed, 14 insertions, 12 deletions
diff --git a/community/py3-executing/APKBUILD b/community/py3-executing/APKBUILD
index f6ab3aad0ed..7c9237509b4 100644
--- a/community/py3-executing/APKBUILD
+++ b/community/py3-executing/APKBUILD
@@ -1,36 +1,38 @@
# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=py3-executing
-pkgver=0.8.3
-pkgrel=0
+pkgver=2.0.1
+pkgrel=1
pkgdesc="Get information about what a Python frame is currently doing"
url="https://github.com/alexmojaki/executing"
arch="noarch"
license="MIT"
depends="python3"
-makedepends="py3-installer py3-setuptools_scm py3-wheel py3-build"
-checkdepends="py3-pytest"
+makedepends="py3-gpep517 py3-setuptools_scm py3-wheel"
+checkdepends="ipython py3-asttokens py3-littleutils py3-pytest"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/alexmojaki/executing/archive/refs/tags/v$pkgver.tar.gz"
builddir="$srcdir/executing-$pkgver"
-options="!check" # tests are failing for some reason
+options="!check" # circular dependency: ipython -> py3-stack_data -> itself
build() {
export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
- python3 -m build \
- --no-isolation \
- --wheel \
- .
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH=$PWD pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- local whl=dist/executing-$pkgver-py2.py3-none-any.whl
+ local whl=.dist/executing-$pkgver-py2.py3-none-any.whl
python3 -m installer --destdir="$pkgdir" "$whl"
}
sha512sums="
-4e01c1f48734c9568412b84160150e7e50ebdf5ba3dd466cf9d37b7f875ca2993915db75e2f6dd8e75e60b7b952fb0146928a41dde100ad38384b9be2ed60522 py3-executing-0.8.3.tar.gz
+8a753aab42ea2d3b61764ee77de3bb52ea7fcc2818298281180ffc47c7b22ee84974ee98b2137250f722ad559be92e72e8fc01d7b2d38ab6a01512618b65d4f3 py3-executing-2.0.1.tar.gz
"