aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-fakeredis/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-fakeredis/APKBUILD')
-rw-r--r--community/py3-fakeredis/APKBUILD38
1 files changed, 27 insertions, 11 deletions
diff --git a/community/py3-fakeredis/APKBUILD b/community/py3-fakeredis/APKBUILD
index 68d950432ce..d0dbd21ba74 100644
--- a/community/py3-fakeredis/APKBUILD
+++ b/community/py3-fakeredis/APKBUILD
@@ -1,30 +1,46 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=py3-fakeredis
_pkgname=${pkgname#py3-}
-pkgver=1.4.5
+pkgver=2.21.2
pkgrel=1
pkgdesc="Fake implementation of redis API for testing purposes"
url="https://pypi.org/project/fakeredis/"
arch="noarch"
license="BSD-3-Clause"
-depends="python3 py3-six py3-redis py3-sortedcontainers"
-makedepends="py3-setuptools"
-checkdepends="py3-hypothesis py3-pytest py3-pytest-mock py3-lupa"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+depends="py3-packaging py3-redis py3-sortedcontainers"
+makedepends="py3-poetry-core py3-gpep517"
+checkdepends="
+ py3-hypothesis
+ py3-lupa
+ py3-pytest
+ py3-pytest-asyncio
+ py3-pytest-mock
+ py3-pytest-xdist
+ "
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ fix-test-exception-msg.patch
+ "
builddir="$srcdir"/$_pkgname-$pkgver
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- # Requires unpackaged 'aioredis'
- rm -f test/test_aioredis.py
- PYTHONPATH="$PWD/build/lib" py.test-3 -m fake
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -n auto
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="94e6a23924990e7d367f17103c6cb0cdb791784ea9d4d14b231a1328c4efaac06621bfb3381e5af6c289928c379bf8cd20eae0b9aeca1129b7500d24bac59682 py3-fakeredis-1.4.5.tar.gz"
+sha512sums="
+0ba5e31e403670e864a5364498e26e818641d0fbba59554b78bd0d82a2d944a730d519184c132bdb367761b830bb3a55b43a957770f833891cccd11d528ff540 py3-fakeredis-2.21.2.tar.gz
+69ffb5c3eb8e991cdfe8900c72df3de421b696ecab55fadd51ba30d3283cf71e64ad80ceef298e0aa93ea1504a4f98ef2df37488d9498050aef01975e67e019c fix-test-exception-msg.patch
+"