aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-fasteners/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-fasteners/APKBUILD')
-rw-r--r--community/py3-fasteners/APKBUILD27
1 files changed, 17 insertions, 10 deletions
diff --git a/community/py3-fasteners/APKBUILD b/community/py3-fasteners/APKBUILD
index 3d39301c952..a44896d0eea 100644
--- a/community/py3-fasteners/APKBUILD
+++ b/community/py3-fasteners/APKBUILD
@@ -2,27 +2,34 @@
# Maintainer: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
pkgname=py3-fasteners
_pyname=fasteners
-pkgver=0.16
+pkgver=0.19
pkgrel=1
pkgdesc="A python package that provides useful locks"
url="https://github.com/harlowja/fasteners/"
arch="noarch"
license="Apache-2.0"
-depends="python3 py3-monotonic py3-six"
-makedepends="python3-dev py3-setuptools"
+depends="python3"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/f/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir/fasteners-$pkgver"
+options="!check" # no tests
build() {
- python3 setup.py build
-}
-
-check() {
- python3 setup.py check
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/fasteners*.whl
}
-sha512sums="aac91be8f732bcda238c40317359c7faaad632b26473eff940fef0c6c2c227cd83942122c0ec26da236ca8c19d3024798590244ec761c2d2700ffdc7142533da fasteners-0.16.tar.gz"
+sha512sums="
+ac698c590cdb17d202e3a3bca794bf6e3bafac2ddc7b112ca972bfa81f4faa666461f90b6d779536f8edbeb5b56fbbcbe7fa21c612a47bf3e34a4beaf2cd43f3 fasteners-0.19.tar.gz
+"