aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-fastimport/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-fastimport/APKBUILD')
-rw-r--r--community/py3-fastimport/APKBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/community/py3-fastimport/APKBUILD b/community/py3-fastimport/APKBUILD
index 188638b419f..ccd9c9659bb 100644
--- a/community/py3-fastimport/APKBUILD
+++ b/community/py3-fastimport/APKBUILD
@@ -1,16 +1,16 @@
# Maintainer: Pedro Filipe <xpecex@outlook.com>
-
pkgname=py3-fastimport
-pkgver=0.9.8
-_pkgver=$pkgver-5
-pkgrel=1
+pkgver=0.9.14
+pkgrel=2
pkgdesc="VCS fastimport/fastexport parser"
arch="noarch"
url="https://github.com/jelmer/python-fastimport"
license="GPL-2.0-only"
+depends="python3"
makedepends="git py3-setuptools"
-source="https://github.com/jelmer/python-fastimport/archive/debian/$_pkgver.tar.gz"
-builddir="$srcdir/python-fastimport-debian-$_pkgver"
+subpackages="$pkgname-pyc"
+source="https://github.com/jelmer/python-fastimport/archive/refs/tags/fastimport-$pkgver.tar.gz"
+builddir="$srcdir/python-fastimport-fastimport-$pkgver"
build() {
python3 setup.py build
@@ -21,8 +21,10 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
rm -rf "$pkgdir"/usr/lib/python3*/site-packages/fastimport/tests
}
-sha512sums="06b205d00e93fa452c4c5653244c7ce719901d69191dd183b7e20cb877898829ab41937f8f8b63f284e69f4f7c92bcede11f4adab7f91a3b537d83716ad4e4fc 0.9.8-5.tar.gz"
+sha512sums="
+9cc6408ba974d0583d7c0526db3d3bf61e5cfd844e0a771e3a9204f3e9f3003b7ac821d328bb6df9a06c50ab5eed23df48e0dc2baa5d10c06d2d4bab31c20942 fastimport-0.9.14.tar.gz
+"