aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-fastimport/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-fastimport/APKBUILD')
-rw-r--r--community/py3-fastimport/APKBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/community/py3-fastimport/APKBUILD b/community/py3-fastimport/APKBUILD
index aa227d14805..ccd9c9659bb 100644
--- a/community/py3-fastimport/APKBUILD
+++ b/community/py3-fastimport/APKBUILD
@@ -1,13 +1,14 @@
# Maintainer: Pedro Filipe <xpecex@outlook.com>
pkgname=py3-fastimport
-pkgver=0.9.12
-pkgrel=0
+pkgver=0.9.14
+pkgrel=2
pkgdesc="VCS fastimport/fastexport parser"
arch="noarch"
url="https://github.com/jelmer/python-fastimport"
license="GPL-2.0-only"
depends="python3"
makedepends="git py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://github.com/jelmer/python-fastimport/archive/refs/tags/fastimport-$pkgver.tar.gz"
builddir="$srcdir/python-fastimport-fastimport-$pkgver"
@@ -20,10 +21,10 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
rm -rf "$pkgdir"/usr/lib/python3*/site-packages/fastimport/tests
}
sha512sums="
-af9e808b72d0e29b9f77d33ab37f4b65b2f7fd4e129499c24193bbaa25baadf502a8ae3720b53af86862c7bf2977510eeb6d76f0e032dfe8a3fda5c6ddadd6ea fastimport-0.9.12.tar.gz
+9cc6408ba974d0583d7c0526db3d3bf61e5cfd844e0a771e3a9204f3e9f3003b7ac821d328bb6df9a06c50ab5eed23df48e0dc2baa5d10c06d2d4bab31c20942 fastimport-0.9.14.tar.gz
"