aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-fastjsonschema/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-fastjsonschema/APKBUILD')
-rw-r--r--community/py3-fastjsonschema/APKBUILD25
1 files changed, 17 insertions, 8 deletions
diff --git a/community/py3-fastjsonschema/APKBUILD b/community/py3-fastjsonschema/APKBUILD
index f8a52f926b5..1fbcfbfbf8c 100644
--- a/community/py3-fastjsonschema/APKBUILD
+++ b/community/py3-fastjsonschema/APKBUILD
@@ -1,33 +1,42 @@
# Contributor: Aiden Grossman <agrossman154@yahoo.com>
# Maintainer: Aiden Grossman <agrossman154@yahoo.com>
pkgname=py3-fastjsonschema
-pkgver=2.15.3
-pkgrel=0
+pkgver=2.19.1
+pkgrel=1
pkgdesc="Fast JSON schema validator"
url="https://horejsek.github.io/python-fastjsonschema/"
arch="noarch"
license="BSD-3-Clause"
depends="python3"
checkdepends="py3-pytest py3-pytest-benchmark"
-source="$pkgname-$pkgver.tar.gz::https://github.com/horejsek/python-fastjsonschema/archive/refs/tags/v2.15.3.tar.gz"
+makedepends="py3-gpep517 py3-setuptools py3-wheel py3-installer"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/horejsek/python-fastjsonschema/archive/refs/tags/v$pkgver.tar.gz
+ pytest8.patch
+ "
builddir="$srcdir/python-fastjsonschema-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- # first test fails on ppc64le and s390x, rest of disabled tests fail on s390x
- pytest \
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest \
--deselect tests/test_compile_to_code.py::test_compile_to_code_custom_format_with_refs \
--deselect tests/test_compile_to_code.py::test_compile_to_code_ipv6_regex \
--deselect tests/test_compile_to_code.py::test_compile_to_code_custom_format
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-59dfc513de46e9df790edaa1abc994decdf98d65bec8eb8a6ac7211d2277f4e15d521a308e45c6532a232321d8a4655f87b7a01f2d57b9de20246a4d6deeeb9b py3-fastjsonschema-2.15.3.tar.gz
+5121ccd0585ea8a78f44ceca95f3f2b5eb769ac3529998a3e54da9535bec96f7e47f1240b0eba63f6fef2dec91fa86fc6317d9da6eb54fed29076759897a42aa py3-fastjsonschema-2.19.1.tar.gz
+be180edad0bd479bab4b15dbaade4d985d99b1c14666ca1bfbbb3eebc7bdbe34518d0263fd7a45e5ff6cba629ec8652c37adf5dbbf47213ed340d476f01791da pytest8.patch
"