aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-fireflyalgorithm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-fireflyalgorithm/APKBUILD')
-rw-r--r--community/py3-fireflyalgorithm/APKBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/community/py3-fireflyalgorithm/APKBUILD b/community/py3-fireflyalgorithm/APKBUILD
index bece1277d9a..58b5fcb05d0 100644
--- a/community/py3-fireflyalgorithm/APKBUILD
+++ b/community/py3-fireflyalgorithm/APKBUILD
@@ -9,13 +9,15 @@ url="https://github.com/firefly-cpp/FireflyAlgorithm"
arch="noarch"
license="MIT"
depends="python3 py3-numpy"
-makedepends="py3-build py3-poetry-core py3-wheel py3-installer"
+makedepends="py3-gpep517 py3-poetry-core"
checkdepends="py3-pytest"
source="https://github.com/firefly-cpp/FireflyAlgorithm/archive/$pkgver/$_pkgorig-$pkgver.tar.gz"
builddir="$srcdir/FireflyAlgorithm-$pkgver"
build() {
- GIT_DIR="$builddir" python3 -m build --no-isolation --wheel
+ gpep517 build-wheel \
+ --wheel-dir dist \
+ --output-fd 1
}
check() {