aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-flake8/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-flake8/APKBUILD')
-rw-r--r--community/py3-flake8/APKBUILD25
1 files changed, 12 insertions, 13 deletions
diff --git a/community/py3-flake8/APKBUILD b/community/py3-flake8/APKBUILD
index 5cc0b4cd231..8159e6eeccd 100644
--- a/community/py3-flake8/APKBUILD
+++ b/community/py3-flake8/APKBUILD
@@ -1,19 +1,17 @@
# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-flake8
-_pyname=flake8
-pkgver=3.9.2
-pkgrel=0
+pkgver=7.0.0
+pkgrel=1
pkgdesc="modular source code checker"
-url="https://gitlab.com/pycqa/flake8"
+url="https://github.com/PyCQA/flake8"
arch="noarch"
license="MIT"
depends="py3-pyflakes py3-pycodestyle py3-mccabe"
makedepends="py3-setuptools"
checkdepends="py3-pytest py3-pbr py3-atomicwrites py3-attrs py3-pluggy py3-six py3-mock"
-source="https://files.pythonhosted.org/packages/source/f/flake8/flake8-$pkgver.tar.gz
- tests-ignore-deprecated-legacy-version.patch
- "
+subpackages="$pkgname-pyc"
+source="https://github.com/PyCQA/flake8/archive/refs/tags/$pkgver/py3-flake8-$pkgver.tar.gz"
builddir="$srcdir/flake8-$pkgver"
replaces="py-flake8" # Backwards compatibility
@@ -24,21 +22,22 @@ build() {
}
check() {
- PYTHONPATH=$PWD/build/lib python3 -m pytest -v \
+ python3 -m venv --clear --without-pip --system-site-packages testenv
+ testenv/bin/python3 setup.py install
+ testenv/bin/python3 -m pytest -v \
--deselect=tests/integration/test_api_legacy.py::test_legacy_api \
--deselect=tests/integration/test_main.py \
--deselect=tests/integration/test_plugins.py \
- --deselect=tests/unit/test_setuptools_command.py::test_package_files_removes_submodules
+ --deselect=tests/unit/test_setuptools_command.py::test_package_files_removes_submodules \
+ --deselect=tests/unit/plugins/pycodestyle_test.py::test_up_to_date
}
package() {
mkdir -p "$pkgdir"/usr/bin
- ln -s flake8 "$pkgdir"/usr/bin/flake8-3
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="
-618fe1b35070b24395e5d4da9fa1b1f6308abf6f85d8de71b8b553f84d70d9cd7d2a6f616fa1418db9a8b5ad3efab038f4e2d7c6020c0c1bdeb8157e666911fd flake8-3.9.2.tar.gz
-d2903dc3d1020839f0546ad598745f598a79131f78a8081a19665190d78703d88e2657b4cdb82f7781adfb68f38ba890d18f1b49b30091331ae9b5d3aa9bb609 tests-ignore-deprecated-legacy-version.patch
+cebcd61d266c6d2f837178d0708217b471662e81dabaa911850883657307747180173c5f6cde11abc2b14381baecff9d6adeca2979bcb85be03a4a6ff57de2c4 py3-flake8-7.0.0.tar.gz
"