aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-flake8/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-flake8/APKBUILD')
-rw-r--r--community/py3-flake8/APKBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/community/py3-flake8/APKBUILD b/community/py3-flake8/APKBUILD
index 41b78d6fae7..8159e6eeccd 100644
--- a/community/py3-flake8/APKBUILD
+++ b/community/py3-flake8/APKBUILD
@@ -1,17 +1,17 @@
# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-flake8
-_pyname=flake8
-pkgver=4.0.1
-pkgrel=0
+pkgver=7.0.0
+pkgrel=1
pkgdesc="modular source code checker"
-url="https://gitlab.com/pycqa/flake8"
+url="https://github.com/PyCQA/flake8"
arch="noarch"
license="MIT"
depends="py3-pyflakes py3-pycodestyle py3-mccabe"
makedepends="py3-setuptools"
checkdepends="py3-pytest py3-pbr py3-atomicwrites py3-attrs py3-pluggy py3-six py3-mock"
-source="https://files.pythonhosted.org/packages/source/f/flake8/flake8-$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="https://github.com/PyCQA/flake8/archive/refs/tags/$pkgver/py3-flake8-$pkgver.tar.gz"
builddir="$srcdir/flake8-$pkgver"
replaces="py-flake8" # Backwards compatibility
@@ -22,20 +22,22 @@ build() {
}
check() {
- PYTHONPATH=$PWD/build/lib python3 -m pytest -v \
+ python3 -m venv --clear --without-pip --system-site-packages testenv
+ testenv/bin/python3 setup.py install
+ testenv/bin/python3 -m pytest -v \
--deselect=tests/integration/test_api_legacy.py::test_legacy_api \
--deselect=tests/integration/test_main.py \
--deselect=tests/integration/test_plugins.py \
- --deselect=tests/unit/test_setuptools_command.py::test_package_files_removes_submodules
+ --deselect=tests/unit/test_setuptools_command.py::test_package_files_removes_submodules \
+ --deselect=tests/unit/plugins/pycodestyle_test.py::test_up_to_date
}
package() {
mkdir -p "$pkgdir"/usr/bin
- ln -s flake8 "$pkgdir"/usr/bin/flake8-3
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="
-0bdbf0218ce893df1c3e61f51cd3f371a5c72bb49ef78fec39548b1684e49b024e91cf4e3dcea60ba1efc08727985ef485814c372461e062ff4f810da99a1796 flake8-4.0.1.tar.gz
+cebcd61d266c6d2f837178d0708217b471662e81dabaa911850883657307747180173c5f6cde11abc2b14381baecff9d6adeca2979bcb85be03a4a6ff57de2c4 py3-flake8-7.0.0.tar.gz
"