aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-flake8/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-flake8/APKBUILD')
-rw-r--r--community/py3-flake8/APKBUILD28
1 files changed, 17 insertions, 11 deletions
diff --git a/community/py3-flake8/APKBUILD b/community/py3-flake8/APKBUILD
index c14feda827d..8159e6eeccd 100644
--- a/community/py3-flake8/APKBUILD
+++ b/community/py3-flake8/APKBUILD
@@ -1,15 +1,17 @@
# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-flake8
-pkgver=3.8.2
-pkgrel=0
-pkgdesc="A modular source code checker"
-url="https://gitlab.com/pycqa/flake8"
+pkgver=7.0.0
+pkgrel=1
+pkgdesc="modular source code checker"
+url="https://github.com/PyCQA/flake8"
arch="noarch"
license="MIT"
-depends="py3-entrypoints py3-pyflakes py3-pycodestyle py3-mccabe py3-setuptools"
+depends="py3-pyflakes py3-pycodestyle py3-mccabe"
+makedepends="py3-setuptools"
checkdepends="py3-pytest py3-pbr py3-atomicwrites py3-attrs py3-pluggy py3-six py3-mock"
-source="https://files.pythonhosted.org/packages/source/f/flake8/flake8-$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="https://github.com/PyCQA/flake8/archive/refs/tags/$pkgver/py3-flake8-$pkgver.tar.gz"
builddir="$srcdir/flake8-$pkgver"
replaces="py-flake8" # Backwards compatibility
@@ -20,18 +22,22 @@ build() {
}
check() {
- PYTHONPATH=$PWD/build/lib python3 -m pytest -v \
+ python3 -m venv --clear --without-pip --system-site-packages testenv
+ testenv/bin/python3 setup.py install
+ testenv/bin/python3 -m pytest -v \
--deselect=tests/integration/test_api_legacy.py::test_legacy_api \
--deselect=tests/integration/test_main.py \
--deselect=tests/integration/test_plugins.py \
- --deselect=tests/unit/test_setuptools_command.py::test_package_files_removes_submodules
+ --deselect=tests/unit/test_setuptools_command.py::test_package_files_removes_submodules \
+ --deselect=tests/unit/plugins/pycodestyle_test.py::test_up_to_date
}
package() {
mkdir -p "$pkgdir"/usr/bin
- ln -s flake8 "$pkgdir"/usr/bin/flake8-3
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="47c128b7bf430a8c35e496fc778cc99092697d91c873e4d4c5eee9bbd5c08825e3ddb45acb88741cb3e2c28d1f117fc0c00f03b702ba46f0d17e02c06a76c064 flake8-3.8.2.tar.gz"
+sha512sums="
+cebcd61d266c6d2f837178d0708217b471662e81dabaa911850883657307747180173c5f6cde11abc2b14381baecff9d6adeca2979bcb85be03a4a6ff57de2c4 py3-flake8-7.0.0.tar.gz
+"