aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-flask-login/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-flask-login/APKBUILD')
-rw-r--r--community/py3-flask-login/APKBUILD39
1 files changed, 27 insertions, 12 deletions
diff --git a/community/py3-flask-login/APKBUILD b/community/py3-flask-login/APKBUILD
index 5ac16b30178..d7a775f540d 100644
--- a/community/py3-flask-login/APKBUILD
+++ b/community/py3-flask-login/APKBUILD
@@ -1,27 +1,30 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Contributor:
-# Maintainer: Drew DeVault <sir@cmpwn.com>
+# Contributor: Steven Guikal <void@fluix.one>
+# Maintainer: Steven Guikal <void@fluix.one>
pkgname=py3-flask-login
_pkgname=flask-login
-pkgver=0.5.0
-pkgrel=2
+pkgver=0.6.3
+pkgrel=1
pkgdesc="Flask user session management"
-options="!check" # py3-blinker and py3-semantic-version are in testing
url="https://github.com/maxcountryman/flask-login"
arch="noarch"
license="MIT"
depends="
py3-flask
+ py3-werkzeug
"
makedepends="
+ py3-gpep517
py3-setuptools
+ py3-wheel
"
checkdepends="
- py3-nose
- py3-mock
- py3-semantic-version
+ py3-asgiref
py3-blinker
+ py3-pytest
+ py3-semantic-version
"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/maxcountryman/flask-login/archive/$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -29,15 +32,27 @@ replaces="py-flask-login" # Backwards compatibility
provides="py-flask-login=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- nosetests-$(python3 -c 'import sys; print("{}.{}".format(sys.version_info.major, sys.version_info.minor))')
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ # These rely on internal properties of Werkzeug < 2.3
+ .testenv/bin/python3 -m pytest -W ignore::DeprecationWarning \
+ --deselect "tests/test_login.py::LoginTestCase::test_remember_me_accepts_duration_as_int" \
+ --deselect "tests/test_login.py::LoginTestCase::test_remember_me_custom_duration_uses_custom_cookie" \
+ --deselect "tests/test_login.py::LoginTestCase::test_remember_me_refresh_every_request" \
+ --deselect "tests/test_login.py::LoginTestCase::test_remember_me_uses_custom_cookie_parameters"
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="8ffecd2a512738f81ec3901ad30d356b1d63355268f7cf1b427e463d0a271a4623723255e139bbd0f88845d73fa4aab051418b5f68aef0b4576c30294f6207b3 py3-flask-login-0.5.0.tar.gz"
+sha512sums="
+c421f85387b9ba0ba2ad98053cae596dd9bf6119c0a366d2b13c483d4fbf45afc0c0e4d46f35368f42fa088398ace9a0a0aab931826d8612d94f55b95afef71b py3-flask-login-0.6.3.tar.gz
+"