aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-flask-wtf/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-flask-wtf/APKBUILD')
-rw-r--r--community/py3-flask-wtf/APKBUILD29
1 files changed, 20 insertions, 9 deletions
diff --git a/community/py3-flask-wtf/APKBUILD b/community/py3-flask-wtf/APKBUILD
index 43ef53cabfb..20239b9827b 100644
--- a/community/py3-flask-wtf/APKBUILD
+++ b/community/py3-flask-wtf/APKBUILD
@@ -1,16 +1,18 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Contributor: Eivind Uggedal <eivind@uggedal.com>
-# Maintainer:
+# Maintainer: Steven Guikal <void@fluix.one>
pkgname=py3-flask-wtf
-_pkgname=Flask-WTF
-pkgver=0.15.1
-pkgrel=0
+_pkgname=flask_wtf
+pkgver=1.2.1
+pkgrel=1
pkgdesc="Flask WTForms extension"
-url="https://pypi.python.org/pypi/Flask-WTF"
+url="https://pypi.org/project/Flask-WTF"
arch="noarch"
license="BSD-3-Clause"
depends="python3 py3-flask py3-wtforms"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-hatchling"
+checkdepends="py3-pytest py3-wtforms-lang"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -18,13 +20,22 @@ replaces="py-flask-wtf" # Backwards compatibility
provides="py-flask-wtf=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-9741e2c2285a500866b160e8c906c38ca579fdae2235bcba2336c7125ba614a9f75167c82bfcb96a45e553170c5925cb1a530d0164ecc57dc76cf1b560c40855 Flask-WTF-0.15.1.tar.gz
+2a94482cd6aa6db42a6021dd8f03fc75d963b8bba2957652fb509088d63617d586ba459dbb0a22c647e22d72c8ba6a037d2018ef07630d9b8ef82fdddc45f940 flask_wtf-1.2.1.tar.gz
"