aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-flask/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-flask/APKBUILD')
-rw-r--r--community/py3-flask/APKBUILD45
1 files changed, 31 insertions, 14 deletions
diff --git a/community/py3-flask/APKBUILD b/community/py3-flask/APKBUILD
index 040e5f6bb81..d7ac6635beb 100644
--- a/community/py3-flask/APKBUILD
+++ b/community/py3-flask/APKBUILD
@@ -1,35 +1,52 @@
-# Contributor:
-# Maintainer: Drew DeVault <sir@cmpwn.com>
+# Contributor: Steven Guikal <void@fluix.one>
+# Maintainer: Steven Guikal <void@fluix.one>
pkgname=py3-flask
-_pkgname=Flask
-pkgver=2.0.1
-pkgrel=0
+_pkgname=flask
+pkgver=3.0.2
+pkgrel=1
pkgdesc="web development microframework"
-url="http://flask.pocoo.org/"
+url="https://flask.palletsprojects.com/"
arch="noarch"
license="MIT"
-depends="python3 py3-click py3-itsdangerous py3-jinja2 py3-werkzeug"
-makedepends="py3-setuptools"
-checkdepends="py3-pytest py3-pluggy"
+depends="
+ py3-blinker
+ py3-click
+ py3-itsdangerous
+ py3-jinja2
+ py3-werkzeug
+ python3
+ "
+makedepends="
+ py3-gpep517
+ py3-flit-core
+ "
+checkdepends="
+ py3-pytest-xdist
+ "
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
-options="!check" # Remove in 2.0.1
replaces="py-flask" # Backwards compatibility
provides="py-flask=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH="$PWD/build/lib" py.test-3
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -n auto
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-fefed4971f0542b25ba2867919aa54a83b6e3f47e7cee94586543843e7e00ba209ac15d8fe28a3c53981f587aebcf2f3915a49e1a9cd1b729099dccbed3783c2 Flask-2.0.1.tar.gz
+02f937dae7d654f6286eb9fcf2d68d83f3ef56dbc4d59a961ea1bd95d17fac7a5ace3f27ebb03ff0592f6a87361e59934ffda098714fc8a049a487d4c0bbc0ef flask-3.0.2.tar.gz
"