aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-flup/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-flup/APKBUILD')
-rw-r--r--community/py3-flup/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/community/py3-flup/APKBUILD b/community/py3-flup/APKBUILD
index e4d704b765f..379404d0fc9 100644
--- a/community/py3-flup/APKBUILD
+++ b/community/py3-flup/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-flup
_pkgname=flup
pkgver=1.0.3
-pkgrel=2
+pkgrel=7
pkgdesc="WSGI modules for Python"
options="!check" # No testsuite
url="https://www.saddi.com/software/flup/"
@@ -11,19 +11,20 @@ arch="noarch"
license="BSD-2-Clause"
depends="python3"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
replaces="py-flup" # Backwards compatibility
provides="py-flup=$pkgver-r$pkgrel" # Backwards compatibility
-builddir="${srcdir}/${_pkgname}-${pkgver}"
+builddir="$srcdir/$_pkgname-$pkgver"
build() {
python3 setup.py build
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="f165685b39a8539d29d48d0ad3c9c0495f428892b8935545a128730687c658a1e8b74a09c8084dd4a2490b1d26f1382b48c95ba43401171fd46876b068ba2f8e flup-1.0.3.tar.gz"