aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-freezegun/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-freezegun/APKBUILD')
-rw-r--r--community/py3-freezegun/APKBUILD27
1 files changed, 16 insertions, 11 deletions
diff --git a/community/py3-freezegun/APKBUILD b/community/py3-freezegun/APKBUILD
index 118a59763b5..02418384727 100644
--- a/community/py3-freezegun/APKBUILD
+++ b/community/py3-freezegun/APKBUILD
@@ -2,29 +2,34 @@
# Maintainer: Robert Sacks <robert@sacks.email>
pkgname=py3-freezegun
_pyname=freezegun
-pkgver=1.1.0
+pkgver=1.4.0
pkgrel=1
pkgdesc="Let your Python tests travel through time"
-url="https://pypi.org/project/freezegun/"
+url="https://github.com/spulec/freezegun"
arch="noarch"
license="Apache-2.0"
-depends="python3 py3-dateutil py3-six"
-makedepends="py3-setuptools"
-checkdepends="py3-mock py3-pytest py3-nose"
-source="https://files.pythonhosted.org/packages/source/${_pyname%${_pyname#?}}/$_pyname/$_pyname-$pkgver.tar.gz"
+depends="python3 py3-dateutil"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+checkdepends="py3-mock py3-pytest py3-pytest-cov"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/f/freezegun/freezegun-$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- rm -f tests/test_uuid.py
- pytest-3
+ pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/freezegun-*.whl
}
-sha512sums="41d2bd18c5115416679602c53aff10891dd8e97402f641eeb3819a3b84d34351c238dece8e68fe267d572693ea08b421510726b6d7c9fdb1d6d70ddc96954d54 freezegun-1.1.0.tar.gz"
+sha512sums="
+bbdad19b7fc2da9a2851d6b4c14427ccda1f2e06617993cf7173ded65cced9b98d36e1da05a2718b70653a69986cd81d84317003271eda2075177ccf63495b7a freezegun-1.4.0.tar.gz
+"