aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-frozendict/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-frozendict/APKBUILD')
-rw-r--r--community/py3-frozendict/APKBUILD30
1 files changed, 22 insertions, 8 deletions
diff --git a/community/py3-frozendict/APKBUILD b/community/py3-frozendict/APKBUILD
index f64f67dad8b..ce7be906045 100644
--- a/community/py3-frozendict/APKBUILD
+++ b/community/py3-frozendict/APKBUILD
@@ -2,32 +2,46 @@
# Maintainer: Daiki Maekawa <daikimaekawa29@gmail.com>
pkgname=py3-frozendict
_pkgname=frozendict
-pkgver=2.3.2
-pkgrel=0
+pkgver=2.4.1
+pkgrel=1
pkgdesc="immutable dictionary"
url="https://github.com/Marco-Sulla/python-frozendict"
arch="all"
-license="MIT"
-makedepends="py3-setuptools python3-dev"
+license="LGPL-3.0-or-later"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ python3-dev
+ "
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
replaces="py-frozendict" # Backwards compatibility
provides="py-frozendict=$pkgver-r$pkgrel" # Backwards compatibility
+# C extension lacks py311 support
+export FROZENDICT_PURE_PY=1
+
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH=$(echo "$PWD"/build/lib*) pytest -v
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-e6674f12d311ba75ea2a7e7dc70c5ffef5b34e5461858c6a0c145437946a938cf7e93ec2e0d3c9321f3e5ca2c6d3bf4707aa57e36803cccc0bf2f26a6f95e57d frozendict-2.3.2.tar.gz
+3f4daa771bc4dc1cbb37067a1b19e54fb5dd0995710e95eee8b0b51851d14ff7b0e51467d464c0f78a4b1c70aac0dc9b2e4d52877afc0b3b7465e6e6f42fc6f4 frozendict-2.4.1.tar.gz
"