aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-frozendict/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-frozendict/APKBUILD')
-rw-r--r--community/py3-frozendict/APKBUILD43
1 files changed, 32 insertions, 11 deletions
diff --git a/community/py3-frozendict/APKBUILD b/community/py3-frozendict/APKBUILD
index 80c55e44374..ce7be906045 100644
--- a/community/py3-frozendict/APKBUILD
+++ b/community/py3-frozendict/APKBUILD
@@ -2,25 +2,46 @@
# Maintainer: Daiki Maekawa <daikimaekawa29@gmail.com>
pkgname=py3-frozendict
_pkgname=frozendict
-pkgver=1.2
-pkgrel=4
+pkgver=2.4.1
+pkgrel=1
pkgdesc="immutable dictionary"
-url="https://github.com/slezica/python-frozendict"
-options="!check" # No testsuite
-arch="noarch"
-license="MIT"
-makedepends="py3-setuptools"
+url="https://github.com/Marco-Sulla/python-frozendict"
+arch="all"
+license="LGPL-3.0-or-later"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ python3-dev
+ "
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-${pkgver}"
+builddir="$srcdir/$_pkgname-$pkgver"
replaces="py-frozendict" # Backwards compatibility
provides="py-frozendict=$pkgver-r$pkgrel" # Backwards compatibility
+# C extension lacks py311 support
+export FROZENDICT_PURE_PY=1
+
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="095cf5f6f8b02bf5666e04200431992bf4b3160aae3464d528bc256b1ab643e29dda78fe94d9e8c983dbfe66cd2459e0559122e17b6b8660c0552adc5318b3da frozendict-1.2.tar.gz"
+
+sha512sums="
+3f4daa771bc4dc1cbb37067a1b19e54fb5dd0995710e95eee8b0b51851d14ff7b0e51467d464c0f78a4b1c70aac0dc9b2e4d52877afc0b3b7465e6e6f42fc6f4 frozendict-2.4.1.tar.gz
+"