aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-fsspec/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-fsspec/APKBUILD')
-rw-r--r--community/py3-fsspec/APKBUILD35
1 files changed, 23 insertions, 12 deletions
diff --git a/community/py3-fsspec/APKBUILD b/community/py3-fsspec/APKBUILD
index 131ab7efd1a..a42def47f56 100644
--- a/community/py3-fsspec/APKBUILD
+++ b/community/py3-fsspec/APKBUILD
@@ -1,16 +1,17 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-fsspec
-pkgver=2021.08.1
-pkgrel=0
+pkgver=2023.12.2
+pkgrel=2
pkgdesc="A specification for pythonic filesystems"
url="https://github.com/intake/filesystem_spec"
-# mips blocked by py3-numpy
-# s390x blocked by py3-distributed
-arch="noarch !mips !mips64 !s390x"
+arch="noarch"
license="BSD-3-Clause"
-depends="python3"
-makedepends="py3-setuptools"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
checkdepends="
py3-aiohttp
py3-cloudpickle
@@ -20,25 +21,35 @@ checkdepends="
py3-pyftpdlib
py3-pygit2
py3-pytest
+ py3-pytest-asyncio
+ py3-pytest-mock
py3-requests
+ py3-tqdm
"
-source="https://github.com/intake/filesystem_spec/archive/$pkgver/filesystem_spec-$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/intake/filesystem_spec/archive/$pkgver.tar.gz"
builddir="$srcdir/filesystem_spec-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+
# test find and test_dbfs.py require network connections
- pytest -k 'not test_find' \
+ .testenv/bin/python3 -m pytest -k 'not test_find' \
--deselect fsspec/implementations/tests/test_dbfs.py
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-760e556cc54e93dfb7132c38cad753b92c3a23f187c8881c7ae53b0d2a14dcc4004c051a44f4e952c5910f0356dfc0bcaa43e22f910a2a0370d64942b625e758 filesystem_spec-2021.08.1.tar.gz
+960fbee750f4158f98caa57e30cace376f2a59ff20e06badb527d53673ce41a9260e08181a63f02aed4038a86250ea27883481a23d845906ceae8c55ee5477d3 py3-fsspec-2023.12.2.tar.gz
"