aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-fsspec/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-fsspec/APKBUILD')
-rw-r--r--community/py3-fsspec/APKBUILD49
1 files changed, 38 insertions, 11 deletions
diff --git a/community/py3-fsspec/APKBUILD b/community/py3-fsspec/APKBUILD
index f9e88a23c39..a42def47f56 100644
--- a/community/py3-fsspec/APKBUILD
+++ b/community/py3-fsspec/APKBUILD
@@ -1,28 +1,55 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-fsspec
-pkgver=0.8.2
-pkgrel=0
+pkgver=2023.12.2
+pkgrel=2
pkgdesc="A specification for pythonic filesystems"
url="https://github.com/intake/filesystem_spec"
-arch="noarch !mips !mips64 !s390x" # mips* Blocked by py3-numpy, s390x: py3-distributed
+arch="noarch"
license="BSD-3-Clause"
-depends="python3"
-makedepends="py3-setuptools"
-checkdepends="py3-pytest py3-numpy py3-pygit2 py3-requests py3-paramiko py3-pyftpdlib py3-cloudpickle py3-lz4 py3-aiohttp"
-source="https://github.com/intake/filesystem_spec/archive/$pkgver/filesystem_spec-$pkgver.tar.gz"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
+checkdepends="
+ py3-aiohttp
+ py3-cloudpickle
+ py3-lz4
+ py3-numpy
+ py3-paramiko
+ py3-pyftpdlib
+ py3-pygit2
+ py3-pytest
+ py3-pytest-asyncio
+ py3-pytest-mock
+ py3-requests
+ py3-tqdm
+ "
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/intake/filesystem_spec/archive/$pkgver.tar.gz"
builddir="$srcdir/filesystem_spec-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+
+ # test find and test_dbfs.py require network connections
+ .testenv/bin/python3 -m pytest -k 'not test_find' \
+ --deselect fsspec/implementations/tests/test_dbfs.py
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="eb19dff4a6b7552fa1bc1a5b38947bbe1d4e23416218dae7a960424bd15d674f717fc8f39223e20248237787f09b6844b049c8b1adad736e4c0003ba17710972 filesystem_spec-0.8.2.tar.gz"
+sha512sums="
+960fbee750f4158f98caa57e30cace376f2a59ff20e06badb527d53673ce41a9260e08181a63f02aed4038a86250ea27883481a23d845906ceae8c55ee5477d3 py3-fsspec-2023.12.2.tar.gz
+"