aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-gatt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-gatt/APKBUILD')
-rw-r--r--community/py3-gatt/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/community/py3-gatt/APKBUILD b/community/py3-gatt/APKBUILD
new file mode 100644
index 00000000000..8cd7c175e63
--- /dev/null
+++ b/community/py3-gatt/APKBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Martijn Braam <martijn@brixit.nl>
+# Contributor: Martijn Braam <martijn@brixit.nl>
+pkgname=py3-gatt
+pkgver=0.2.6
+pkgrel=5
+pkgdesc="Bluetooth GATT SDK for Python"
+url="https://pypi.org/project/gatt"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
+source="https://github.com/getsenic/gatt-python/archive/$pkgver/gatt-python-$pkgver.tar.gz"
+builddir="$srcdir/gatt-python-$pkgver"
+options="!check" # There's no testsuite
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="0751784e908132fac566f6c5c64de1bb4ca8273e099ff5becae7e5043c2c13ca3a2ef63e5585ac225088a83af15c794b797268c3abeeaedccc058fbd5cee0a09 gatt-python-0.2.6.tar.gz"