aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-gatt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-gatt/APKBUILD')
-rw-r--r--community/py3-gatt/APKBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/community/py3-gatt/APKBUILD b/community/py3-gatt/APKBUILD
index 9b9fa435af7..4439708a520 100644
--- a/community/py3-gatt/APKBUILD
+++ b/community/py3-gatt/APKBUILD
@@ -2,13 +2,14 @@
# Contributor: Martijn Braam <martijn@brixit.nl>
pkgname=py3-gatt
pkgver=0.2.6
-pkgrel=0
-pkgdesc="Python 2 and 3 compatibility library"
-url="https://pypi.python.org/pypi/gatt"
+pkgrel=6
+pkgdesc="Bluetooth GATT SDK for Python"
+url="https://pypi.org/project/gatt"
arch="noarch"
license="MIT"
depends="python3"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://github.com/getsenic/gatt-python/archive/$pkgver/gatt-python-$pkgver.tar.gz"
builddir="$srcdir/gatt-python-$pkgver"
options="!check" # There's no testsuite
@@ -18,7 +19,7 @@ build() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="0751784e908132fac566f6c5c64de1bb4ca8273e099ff5becae7e5043c2c13ca3a2ef63e5585ac225088a83af15c794b797268c3abeeaedccc058fbd5cee0a09 gatt-python-0.2.6.tar.gz"