aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-genty/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-genty/APKBUILD')
-rw-r--r--community/py3-genty/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/py3-genty/APKBUILD b/community/py3-genty/APKBUILD
new file mode 100644
index 00000000000..b540497f3ec
--- /dev/null
+++ b/community/py3-genty/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=py3-genty
+pkgver=1.3.2
+pkgrel=5
+pkgdesc="Allows you to run a test with multiple data sets"
+url="https://github.com/box/genty"
+arch="noarch"
+license="Apache-2.0"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="
+ py3-mock
+ py3-pytest
+ "
+subpackages="$pkgname-pyc"
+source="https://pypi.python.org/packages/source/g/genty/genty-$pkgver.tar.gz"
+options="!check" # Broken
+builddir="$srcdir/genty-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ pytest
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="
+cfe984dfe5af48ba9f4f959a1d0ab1d331d3c2fdb64c680572e5652b845e5c290097ec3ed2b4e472a563cd6ab79489124f6eb212902a05a2f1ce5ff254a82e13 genty-1.3.2.tar.gz
+"