aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-geoip2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-geoip2/APKBUILD')
-rw-r--r--community/py3-geoip2/APKBUILD26
1 files changed, 16 insertions, 10 deletions
diff --git a/community/py3-geoip2/APKBUILD b/community/py3-geoip2/APKBUILD
index ecd08fa22c4..ce1a5d19fdf 100644
--- a/community/py3-geoip2/APKBUILD
+++ b/community/py3-geoip2/APKBUILD
@@ -1,17 +1,18 @@
# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=py3-geoip2
-pkgver=4.5.0
-pkgrel=0
+pkgver=4.8.0
+pkgrel=1
pkgdesc="API for the GeoIP2 web services and databases"
options="!check" # Requires unpackaged mocket
url="https://www.maxmind.com/en/home"
arch="noarch"
license="Apache-2.0"
depends="py3-requests py3-maxminddb py3-aiohttp py3-urllib3"
-makedepends="python3-dev libmaxminddb-dev py3-setuptools"
+makedepends="python3-dev py3-gpep517 py3-wheel libmaxminddb-dev py3-setuptools"
checkdepends="py3-nose py3-mock"
-_test_data_commit=cbaa463dc6950ababbf678ca85fb3833b81c76d3
+_test_data_commit=1271107ccad72c320bc7dc8aefd767cba550101a
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/maxmind/GeoIP2-python/archive/v$pkgver.tar.gz
MaxMind-DB-test-data-$_test_data_commit.tar.gz::https://github.com/maxmind/MaxMind-DB/archive/$_test_data_commit.tar.gz"
builddir="$srcdir/GeoIP2-python-$pkgver"
@@ -20,23 +21,28 @@ prepare() {
cd "$srcdir"
# Submodule required for tests
- cp -r "MaxMind-DB-$_test_data_commit/"* "$builddir/tests/data"
+ cp -r "MaxMind-DB-$_test_data_commit/" -T "$builddir/tests/data"
default_prepare
}
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ pyton3 -m venv --clear --without-pip --system-site-packages .testenv
+ ./testenv/bin/python3 -m installed .dist/*.whl
+ ./testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-a3701b7dbaf3c5b20b0f2b19742ecbb36da806fc7e156dc64852a2cdd9cfab2dfba47367b15bbe848016f36d20b30e91dc662e41e730d15476372cd872c01cd7 py3-geoip2-4.5.0.tar.gz
-337552c1d6524ba31c1d3df55c0b6137ca2d5115529b8c1a619c82baa198886c274bac4228e456273851bddc46ca983ad2be6329b8f19d2769b745fb2c0f96b1 MaxMind-DB-test-data-cbaa463dc6950ababbf678ca85fb3833b81c76d3.tar.gz
+e22fac4c5016d6bc17a2e7902ea61f5ac43526a3d86c21a3199a409d084fd7a60001ed553a2c3d355636a06a73baad15014dc0ed41e5bb0eb93cefde5a14509e py3-geoip2-4.8.0.tar.gz
+a028b07cfdb84b98629e66937472feb291e0c022cf226513d765b21c420672620ff00b9004aa4cf1519d76a428a33600c453335e2fa9832e78e4621307b5723b MaxMind-DB-test-data-1271107ccad72c320bc7dc8aefd767cba550101a.tar.gz
"