aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-gettext/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-gettext/APKBUILD')
-rw-r--r--community/py3-gettext/APKBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/community/py3-gettext/APKBUILD b/community/py3-gettext/APKBUILD
index 0496c27f6cf..b52a31e0207 100644
--- a/community/py3-gettext/APKBUILD
+++ b/community/py3-gettext/APKBUILD
@@ -2,30 +2,37 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=py3-gettext
_pkgname=gettext
-pkgver=4.0
-pkgrel=4
+pkgver=5.0
+pkgrel=1
pkgdesc="Python implementation of Gettext"
url="https://github.com/hannosch/python-gettext"
arch="noarch"
license="GPL-3.0-or-later"
makedepends="py3-setuptools"
-checkdepends="py3-tox py3-six"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/hannosch/python-gettext/archive/$pkgver.tar.gz"
builddir="$srcdir/python-$_pkgname-$pkgver"
replaces="py-gettext" # Backwards compatibility
provides="py-gettext=$pkgver-r$pkgrel" # Backwards compatibility
+# some files are generated incorrectly
+case "$CARCH" in
+s390x) options="$options !check"
+esac
+
build() {
python3 setup.py build
}
check() {
- python3 setup.py check
+ PYTHONPATH=build/lib python3 -m unittest discover -s src/pythongettext
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="b33786ddd32d5e6c31b062ea88131788f8ba68fcd40e2a519e433584b662f766fd866fc249bc77ae06174d133fbae63b0ef9acf45161ff7d79ceab893afde873 py3-gettext-4.0.tar.gz"
+sha512sums="
+87a1ff704aa43b495bfecf13f6a1ef95383a81c29c8044c670b25d245b666fd42942ad53cc866177e371661d1f9e75daefd9bddd76436cd3a151b27ada2122ec py3-gettext-5.0.tar.gz
+"