aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-gitdb2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-gitdb2/APKBUILD')
-rw-r--r--community/py3-gitdb2/APKBUILD31
1 files changed, 24 insertions, 7 deletions
diff --git a/community/py3-gitdb2/APKBUILD b/community/py3-gitdb2/APKBUILD
index a8d0833844c..8c0f889db41 100644
--- a/community/py3-gitdb2/APKBUILD
+++ b/community/py3-gitdb2/APKBUILD
@@ -1,30 +1,47 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer:
pkgname=py3-gitdb2
-pkgver=4.0.7
+pkgver=4.0.11
pkgrel=1
pkgdesc="Git Object Database"
-options="!check" # (failures=1,errors=9)
url="https://github.com/gitpython-developers/gitdb"
arch="noarch"
license="BSD-3-Clause"
depends="python3 py3-smmap2"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/gitpython-developers/gitdb/archive/$pkgver.tar.gz"
builddir="$srcdir/gitdb-$pkgver"
+prepare() {
+ default_prepare
+
+ git init -q .
+ git config --local user.name "example"
+ git config --local user.email "example@example.com"
+ git add .
+ git commit -m "tests"
+}
+
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 -m unittest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest \
+ -k 'not test_pack_writing'
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-54d3bec59866525c5ca4854290358d8b93555ceb51b4da32dc4ef1679e24922b9d3e1ec023b8089057aa6d101edde5824c7fa33902ebbeb8c7ef4add46a29aa0 py3-gitdb2-4.0.7.tar.gz
+b6802b017dbfb3b8c72d174a25bd180ff335c8560f7b4bc27884ad5f4d7bc106a43d11d57a838a2efdaae9723269bfc57b0ff68ca7fb94eb1ad3e2cbbf014a05 py3-gitdb2-4.0.11.tar.gz
"