aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-gitpython/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-gitpython/APKBUILD')
-rw-r--r--community/py3-gitpython/APKBUILD43
1 files changed, 34 insertions, 9 deletions
diff --git a/community/py3-gitpython/APKBUILD b/community/py3-gitpython/APKBUILD
index a0c845c0965..55ac08120ec 100644
--- a/community/py3-gitpython/APKBUILD
+++ b/community/py3-gitpython/APKBUILD
@@ -1,29 +1,54 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-gitpython
-pkgver=3.1.11
+pkgver=3.1.42
pkgrel=0
pkgdesc="Python3 Git Library"
url="https://github.com/gitpython-developers/GitPython"
arch="noarch"
license="BSD-3-Clause"
-depends="python3 py3-gitdb2 git"
-makedepends="py3-setuptools"
-checkdepends="py3-pytest"
+depends="
+ git
+ py3-gitdb2
+ py3-typing-extensions
+ "
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
+checkdepends="
+ py3-pytest
+ py3-pytest-cov
+ py3-pytest-sugar
+ py3-toml
+ "
+subpackages="$pkgname-pyc"
source="https://github.com/gitpython-developers/GitPython/archive/$pkgver/GitPython-$pkgver.tar.gz"
builddir="$srcdir/GitPython-$pkgver"
+# secfixes:
+# 3.1.37-r0:
+# - CVE-2023-41040
+
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- # There are more tests but they require a specific git configuration
- pytest test/test_config.py
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ # There are more tests but they require testing/py3-ddt
+ .testenv/bin/python3 -m pytest test/test_config.py
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="c17130909e391fd5601643a70546016ca37e868113a6304bd5e5a155833a8f220ffeebee28c356a7fd58ba4023e2c725f20807949f1efc13e1006533c89a169d GitPython-3.1.11.tar.gz"
+sha512sums="
+9ec51ad98e79a807dad72cb54e755fd7fd9651c6bf25f7e11ea4dac5bd01403d1da833ca4bf6ee72441c5015a515998b4dec41d9e24ce45ad313bfcee244cf2e GitPython-3.1.42.tar.gz
+"