aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-google-api-core/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-google-api-core/APKBUILD')
-rw-r--r--community/py3-google-api-core/APKBUILD47
1 files changed, 33 insertions, 14 deletions
diff --git a/community/py3-google-api-core/APKBUILD b/community/py3-google-api-core/APKBUILD
index ae970b23065..47b51274806 100644
--- a/community/py3-google-api-core/APKBUILD
+++ b/community/py3-google-api-core/APKBUILD
@@ -1,32 +1,51 @@
# Contributor: Keith Maxwell <keith.maxwell@gmail.com>
# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
pkgname=py3-google-api-core
-_pyname=google-api-core
-pkgver=1.17.0
+pkgver=2.11.1
pkgrel=1
pkgdesc="Google API client core library"
-options="!check" # Can't find its own module for testing
url="https://github.com/googleapis/python-api-core"
-arch="noarch !ppc64le" # limited by py3-grpcio
+arch="noarch"
license="Apache-2.0"
-depends="python3 py3-setuptools py3-googleapis-common-protos py3-protobuf
- py3-tz py3-requests"
-checkdepends="py3-pytest py3-mock py3-google-auth py3-grpcio"
+depends="
+ py3-google-auth
+ py3-googleapis-common-protos
+ py3-protobuf
+ py3-requests
+ python3
+ "
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
+checkdepends="
+ py3-grpcio
+ py3-mock
+ py3-pytest
+ "
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/g/google-api-core/google-api-core-$pkgver.tar.gz"
-
-builddir="$srcdir/$_pyname-$pkgver"
+builddir="$srcdir/google-api-core-$pkgver"
+options="!check" # missing some "proto" dep
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH="$PWD/build/lib" python3 -m pytest \
- --deselect tests/unit/test_retry.py::TestRetry::test___call___and_execute_retry_hitting_deadline
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="2fde24d23e912898b91807fd674f23f7c7483fe3f8b8f6c7e05851fd5f908accf709ebb02f6f85e34c241d30dd91aace11cb3757f02ec0fabea34e107bf8e5a8 google-api-core-1.17.0.tar.gz"
+sha512sums="
+8b36e598153ce121d4d536a01202e4608ff0fd361326bb4b55c76d05ab420d27a8cb001cbd9e23f1051f311cd3d35f179f108078e12fcaa81ba6960729230f5a google-api-core-2.11.1.tar.gz
+"