aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-google-api-python-client/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-google-api-python-client/APKBUILD')
-rw-r--r--community/py3-google-api-python-client/APKBUILD57
1 files changed, 35 insertions, 22 deletions
diff --git a/community/py3-google-api-python-client/APKBUILD b/community/py3-google-api-python-client/APKBUILD
index 6d0bd155e6d..61d706e0347 100644
--- a/community/py3-google-api-python-client/APKBUILD
+++ b/community/py3-google-api-python-client/APKBUILD
@@ -2,42 +2,55 @@
# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
pkgname=py3-google-api-python-client
_pkgname=google-api-python-client
-pkgver=1.8.3
-pkgrel=2
+pkgver=2.96.0
+pkgrel=1
pkgdesc="Google API Client Library for Python"
-url="https://github.com/google/google-api-python-client"
-arch="noarch !ppc64le" # limited by py3-grpcio
+url="https://github.com/googleapis/google-api-python-client"
+arch="noarch"
license="Apache-2.0"
-depends="py3-google-auth py3-google-auth-httplib2 py3-uritemplate py3-six py3-httplib2
- py3-oauth2client py3-google-api-core"
-makedepends="py3-setuptools"
-checkdepends="py3-google-auth py3-google-auth-httplib2 py3-openssl py3-pytest py3-mock"
-source="https://files.pythonhosted.org/packages/source/g/google-api-python-client/google-api-python-client-$pkgver.tar.gz
- https://github.com/googleapis/google-api-python-client/commit/8ed1dcdf85556905681146bf5fcadf6540a508e9.patch
- unittest2.patch
+depends="
+ py3-google-api-core
+ py3-google-auth
+ py3-google-auth-httplib2
+ py3-httplib2
+ py3-oauth2client
+ py3-uritemplate
"
-
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
+checkdepends="
+ py3-mock
+ py3-openssl
+ py3-parameterized
+ py3-pytest
+ "
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/g/google-api-python-client/google-api-python-client-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
replaces="py-google-api-python-client" # Backwards compatibility
provides="py-google-api-python-client=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 -m pytest tests
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-
- # Fix permissions
- _site_packages=$(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")
- chmod -R a+r "$pkgdir$_site_packages"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="4352fd2b25c079418af509f806f09620df7a6630c015de21a5fa05a8c8bfba342d1ac849da5b87de6b04ae6a842c972f86616fc3f133611697f48406beaaee1d google-api-python-client-1.8.3.tar.gz
-ab891187e44180f9ca92408128618cdb93d20fb9af61300a6364da631bf9db8dcd23c4b252b94d486b90a1a435f9fec30355fad8b8659df5e342679bbdc37cdd 8ed1dcdf85556905681146bf5fcadf6540a508e9.patch
-e47ecc9a4522520b8be00702e7ad1b358c6683fe4daf3b16446c2e96a3c42e698244bd7e54be7245b2cdd800e7326a2c1587643ca7ee60a1dec843b3f3c49cf5 unittest2.patch"
+sha512sums="
+94b59d38df431b1624192946f84229f100870c44eaa304f740dc1ff8973bf54f9c1bf59315aa826f122ec4b46c21507d4f2c5f691a18804e57d81379848346e8 google-api-python-client-2.96.0.tar.gz
+"