aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-google-auth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-google-auth/APKBUILD')
-rw-r--r--community/py3-google-auth/APKBUILD46
1 files changed, 25 insertions, 21 deletions
diff --git a/community/py3-google-auth/APKBUILD b/community/py3-google-auth/APKBUILD
index 3e8f6c3a510..e8f79456e67 100644
--- a/community/py3-google-auth/APKBUILD
+++ b/community/py3-google-auth/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
pkgname=py3-google-auth
_pyname=google-auth
-pkgver=1.19.2
+pkgver=2.22.0
pkgrel=1
pkgdesc="Google authentication library for Python."
url="https://google-auth.readthedocs.io/en/latest/"
@@ -10,48 +10,52 @@ arch="noarch"
license="Apache-2.0"
depends="
python3
- py3-cachetools<5.0
+ py3-cachetools
py3-asn1-modules
py3-rsa
- py3-setuptools
py3-six
"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
checkdepends="
+ py3-certifi
+ py3-cryptography
py3-flask
py3-freezegun
+ py3-grpcio
py3-mock
py3-oauth2client
py3-openssl
py3-pytest
py3-pytest-cov
py3-pytest-localserver
+ py3-pyu2f
py3-requests
py3-responses
py3-urllib3
- py3-cryptography
- py3-certifi
- "
-case "$CARCH" in
- ppc64le) ;; # no py3-grpcio, -needs UnscaledCycleClock::Frequency()
- *) checkdepends="$checkdepends py3-grpcio" ;; # to run full suite
-esac
-
-source="https://files.pythonhosted.org/packages/source/g/google-auth/google-auth-$pkgver.tar.gz
- remove-unnecessary-dependencies.patch
"
-
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/g/google-auth/google-auth-$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
build() {
- python3 setup.py build
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
python3 -m pytest
}
-sha512sums="f520f889c0fb4514ca61b5e43ca893263e2f5048c5d2265dd8bfe9c102f0918611c40001589cb395a689f2294461c069105a09bf8e9607f2e7e9aef5e6794f7d google-auth-1.19.2.tar.gz
-8a8e00659b24c226e1533c869eab26e9fb3a75606073ddd29adc97f3fcb8ed0ce874a53936ba77125e464f5d69e230ebdda5b196533c7f0476c75aa16dc1aa0a remove-unnecessary-dependencies.patch"
+
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+}
+
+sha512sums="
+c2c04e9ad367dd96bf00af7b19c7d897dd9fe3f8e9318b7436ec85a5c146b29c273cc718932956e97b2e4a1e2f12d0d10e835b6cf0f4e46ee19f6aaeed492b5e google-auth-2.22.0.tar.gz
+"