aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-google-auth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-google-auth/APKBUILD')
-rw-r--r--community/py3-google-auth/APKBUILD45
1 files changed, 28 insertions, 17 deletions
diff --git a/community/py3-google-auth/APKBUILD b/community/py3-google-auth/APKBUILD
index 1fe5ea05c2a..e8f79456e67 100644
--- a/community/py3-google-auth/APKBUILD
+++ b/community/py3-google-auth/APKBUILD
@@ -2,49 +2,60 @@
# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
pkgname=py3-google-auth
_pyname=google-auth
-pkgver=1.11.2
-pkgrel=0
+pkgver=2.22.0
+pkgrel=1
pkgdesc="Google authentication library for Python."
url="https://google-auth.readthedocs.io/en/latest/"
arch="noarch"
license="Apache-2.0"
depends="
python3
- py3-cachetools<5.0
+ py3-cachetools
py3-asn1-modules
- py3-rsa<4.1
- py3-setuptools
+ py3-rsa
py3-six
"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
checkdepends="
+ py3-certifi
+ py3-cryptography
py3-flask
py3-freezegun
+ py3-grpcio
+ py3-mock
py3-oauth2client
+ py3-openssl
py3-pytest
py3-pytest-cov
py3-pytest-localserver
+ py3-pyu2f
py3-requests
py3-responses
py3-urllib3
- py3-cryptography
- "
-source="https://files.pythonhosted.org/packages/source/g/$_pyname/$_pyname-$pkgver.tar.gz
- 10-use-mock-from-standard-library.patch
"
-
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/g/google-auth/google-auth-$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+check() {
+ python3 -m pytest
}
-check() {
- pytest-3 # skips grpc tests
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="39412055b3400792209eee4dec147435e38abbba0a60e5ad2668130b062360fb6ebfac5ecd29f36833c254756d4fda4a0a5ab4ea4c4faa5be7950e5c20781517 google-auth-1.11.2.tar.gz
-34c6eeaf2e83370ec78c5cfd99b54940a3c3027ec361c162c8d5f653426d3fca48705ad76b97660489ffd5c9e0be49a5f9dd5a4df9831777cd6855c9288a9150 10-use-mock-from-standard-library.patch"
+sha512sums="
+c2c04e9ad367dd96bf00af7b19c7d897dd9fe3f8e9318b7436ec85a5c146b29c273cc718932956e97b2e4a1e2f12d0d10e835b6cf0f4e46ee19f6aaeed492b5e google-auth-2.22.0.tar.gz
+"