aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-google-auth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-google-auth/APKBUILD')
-rw-r--r--community/py3-google-auth/APKBUILD57
1 files changed, 42 insertions, 15 deletions
diff --git a/community/py3-google-auth/APKBUILD b/community/py3-google-auth/APKBUILD
index 774e851ad64..e8f79456e67 100644
--- a/community/py3-google-auth/APKBUILD
+++ b/community/py3-google-auth/APKBUILD
@@ -2,33 +2,60 @@
# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
pkgname=py3-google-auth
_pyname=google-auth
-pkgver=1.6.3
+pkgver=2.22.0
pkgrel=1
pkgdesc="Google authentication library for Python."
url="https://google-auth.readthedocs.io/en/latest/"
arch="noarch"
license="Apache-2.0"
-depends="python3 py3-cachetools py3-asn1-modules py3-setuptools py3-rsa py3-six"
-checkdepends="py3-certifi py3-flask py3-oauth2client py3-pytest py3-pytest-cov
- py3-pytest-localserver py3-requests py3-requests-oauthlib py3-urllib3
- py3-cryptography"
-source="https://files.pythonhosted.org/packages/source/g/${_pyname}/${_pyname}-${pkgver}.tar.gz
- 10-use-mock-from-standard-library.patch
+depends="
+ python3
+ py3-cachetools
+ py3-asn1-modules
+ py3-rsa
+ py3-six
"
-
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
+checkdepends="
+ py3-certifi
+ py3-cryptography
+ py3-flask
+ py3-freezegun
+ py3-grpcio
+ py3-mock
+ py3-oauth2client
+ py3-openssl
+ py3-pytest
+ py3-pytest-cov
+ py3-pytest-localserver
+ py3-pyu2f
+ py3-requests
+ py3-responses
+ py3-urllib3
+ "
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/g/google-auth/google-auth-$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+check() {
+ python3 -m pytest
}
-check() {
- pytest-3 # skips grpc tests
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="47a3e9390428ffa58946c348d4e1a1bfe1290d6e06b75924bbacb37d5af929050690ef5c13820468de805646f4686c035b00dfe947c090d53568dd85d804af5e google-auth-1.6.3.tar.gz
-4242765bce157f7e3ba42b668396d7629b78a389f82832960b689741c0f30f6a1a3d07e217b37c6c6515813b6a7783e1cc9308046bc38d9fcb0c596bf3f896ff 10-use-mock-from-standard-library.patch"
+sha512sums="
+c2c04e9ad367dd96bf00af7b19c7d897dd9fe3f8e9318b7436ec85a5c146b29c273cc718932956e97b2e4a1e2f12d0d10e835b6cf0f4e46ee19f6aaeed492b5e google-auth-2.22.0.tar.gz
+"