aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-gpxpy/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-gpxpy/APKBUILD')
-rw-r--r--community/py3-gpxpy/APKBUILD26
1 files changed, 19 insertions, 7 deletions
diff --git a/community/py3-gpxpy/APKBUILD b/community/py3-gpxpy/APKBUILD
index e65bf9de916..6c759ac0abf 100644
--- a/community/py3-gpxpy/APKBUILD
+++ b/community/py3-gpxpy/APKBUILD
@@ -1,27 +1,39 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-gpxpy
-pkgver=1.4.2
-pkgrel=2
+pkgver=1.6.2
+pkgrel=0
pkgdesc="Python3 GPX parser"
url="https://github.com/tkrajina/gpxpy"
arch="noarch"
license="Apache-2.0"
depends="python3"
-makedepends="py3-setuptools"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/g/gpxpy/gpxpy-$pkgver.tar.gz"
builddir="$srcdir/gpxpy-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 -m unittest test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m unittest test
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="0c23d908b0d591ffb569c68f108812aa19ca70709fee95741d25cb472a7602f3418f5de3314af35b25400869fec1c26cca5e7188c12693a48d7f0563168a3050 gpxpy-1.4.2.tar.gz"
+sha512sums="
+441b0a0f3c437e7df78aeaa42111e933a161a4e40ff09b3b74cff18f0da533704b207cee9dc870b88515d54296fa559f7ba0d29e8ddad73f3ca07416ffef26c1 gpxpy-1.6.2.tar.gz
+"