aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-graphviz/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-graphviz/APKBUILD')
-rw-r--r--community/py3-graphviz/APKBUILD25
1 files changed, 16 insertions, 9 deletions
diff --git a/community/py3-graphviz/APKBUILD b/community/py3-graphviz/APKBUILD
index f51019e20e7..d3b9f490dd5 100644
--- a/community/py3-graphviz/APKBUILD
+++ b/community/py3-graphviz/APKBUILD
@@ -1,25 +1,25 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-graphviz
-pkgver=0.16
+pkgver=0.20.3
pkgrel=1
pkgdesc="Simple interface for Graphviz"
url="https://github.com/xflr6/graphviz"
arch="noarch"
license="MIT"
depends="
- graphviz
+ graphviz
python3
"
makedepends="py3-setuptools"
checkdepends="
+ font-cantarell
py3-pytest-cov
py3-pytest-mock
py3-pytest
"
-source="https://github.com/xflr6/graphviz/archive/$pkgver/graphviz-$pkgver.tar.gz
- use-std-mock.patch
- "
+subpackages="$pkgname-pyc"
+source="https://github.com/xflr6/graphviz/archive/$pkgver/graphviz-$pkgver.tar.gz"
builddir="$srcdir/graphviz-$pkgver"
replaces="py-graphviz" # for backwards compatibility
@@ -30,13 +30,20 @@ build() {
}
check() {
+ # ignore conftest: https://github.com/pytest-dev/pytest/issues/12123
# test_pipe requires graphviz built with triangulation library
- pytest -k "not test_pipe"
+ # jupyter_integration requires graphviz built with jpeg support / libgd
+ pytest \
+ --ignore tests/conftest.py \
+ --ignore tests/backend/conftest.py \
+ --deselect tests/backend/test_piping.py::test_pipe \
+ --deselect graphviz/jupyter_integration.py::graphviz.jupyter_integration.JupyterIntegration._repr_mimebundle_
}
package() {
- python3 setup.py --quiet install --prefix=/usr --root="$pkgdir"
+ python3 setup.py --quiet install --skip-build --root="$pkgdir"
}
-sha512sums="99596f71d2ea8162b051514bcc872e948ac77c9c9ba5201c7e6afb5a4debb4c3c1d27835c213a7cb9fd68ff3270b6cfdf874a89419c9bbbbc92b49b260169993 graphviz-0.16.tar.gz
-d84171748e36cb48c6c6fa38e0596b42946cee3ad3a3a6b607da4828e138f34656a40ca4d91ddcebb89669edec29a7dd4c227d13d3900c51b14bfa971f874f4f use-std-mock.patch"
+sha512sums="
+e920093e499a539b1c8b5b250f2feeb0829caffd7ad27ae762cb7d4f8762e20bc4c9c72ac2a8d0efbbc81a3eef3289f5f66eed6c6db45353c9d802594449f6ae graphviz-0.20.3.tar.gz
+"