aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-graphviz/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-graphviz/APKBUILD')
-rw-r--r--community/py3-graphviz/APKBUILD17
1 files changed, 12 insertions, 5 deletions
diff --git a/community/py3-graphviz/APKBUILD b/community/py3-graphviz/APKBUILD
index a9b0e1a3953..d3b9f490dd5 100644
--- a/community/py3-graphviz/APKBUILD
+++ b/community/py3-graphviz/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-graphviz
-pkgver=0.17
+pkgver=0.20.3
pkgrel=1
pkgdesc="Simple interface for Graphviz"
url="https://github.com/xflr6/graphviz"
@@ -13,11 +13,12 @@ depends="
"
makedepends="py3-setuptools"
checkdepends="
+ font-cantarell
py3-pytest-cov
py3-pytest-mock
py3-pytest
- ttf-cantarell
"
+subpackages="$pkgname-pyc"
source="https://github.com/xflr6/graphviz/archive/$pkgver/graphviz-$pkgver.tar.gz"
builddir="$srcdir/graphviz-$pkgver"
@@ -29,14 +30,20 @@ build() {
}
check() {
+ # ignore conftest: https://github.com/pytest-dev/pytest/issues/12123
# test_pipe requires graphviz built with triangulation library
- pytest -k "not test_pipe"
+ # jupyter_integration requires graphviz built with jpeg support / libgd
+ pytest \
+ --ignore tests/conftest.py \
+ --ignore tests/backend/conftest.py \
+ --deselect tests/backend/test_piping.py::test_pipe \
+ --deselect graphviz/jupyter_integration.py::graphviz.jupyter_integration.JupyterIntegration._repr_mimebundle_
}
package() {
- python3 setup.py --quiet install --prefix=/usr --root="$pkgdir"
+ python3 setup.py --quiet install --skip-build --root="$pkgdir"
}
sha512sums="
-640b151ab4d01acfe3b4a40b9c08877623a1534eeac334ad846cde2a9402b2c15958b30b05d9d876d03e65efbb94d726c74a51d7f86aed137b9c58f2fe9f08ce graphviz-0.17.tar.gz
+e920093e499a539b1c8b5b250f2feeb0829caffd7ad27ae762cb7d4f8762e20bc4c9c72ac2a8d0efbbc81a3eef3289f5f66eed6c6db45353c9d802594449f6ae graphviz-0.20.3.tar.gz
"