aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-greenlet/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-greenlet/APKBUILD')
-rw-r--r--community/py3-greenlet/APKBUILD43
1 files changed, 10 insertions, 33 deletions
diff --git a/community/py3-greenlet/APKBUILD b/community/py3-greenlet/APKBUILD
index 26f85c54009..282481b7d07 100644
--- a/community/py3-greenlet/APKBUILD
+++ b/community/py3-greenlet/APKBUILD
@@ -1,58 +1,35 @@
# Maintainer: Elizabeth Jennifer Myers <elizabeth@sporksirc.net>
# Contributor: Elizabeth Jennifer Myers <elizabeth@sporksirc.net>
-pkgname=py-greenlet
+pkgname=py3-greenlet
_pkgname=greenlet
pkgver=0.4.15
-pkgrel=1
+pkgrel=2
pkgdesc="Lightweight in-process concurrent programming"
url="https://pypi.python.org/pypi/greenlet"
arch="all"
license="MIT"
-depends=""
-makedepends="python2-dev py-setuptools python3-dev"
-subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2"
+makedepends="py3-setuptools python3-dev"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
ppc64le_clobbering.patch"
-
builddir="$srcdir/$_pkgname-$pkgver"
+replaces="py-greenlet" # Backwards compatibility
+provides="py-greenlet=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
case "$CARCH" in
- mips*) ;;
- *) export CFLAGS="-O0" CPPFLAGS="-O0" CXXFLAGS="-O0" ;;
+ mips*) ;;
+ *) export CFLAGS="-O0" CPPFLAGS="-O0" CXXFLAGS="-O0" ;;
esac
- python2 setup.py build
python3 setup.py build
}
-package() {
- mkdir -p "$pkgdir"
-}
-
check() {
- cd "$builddir"
- python2 setup.py test
python3 setup.py test
}
-_py() {
- local python=$1
- pkgdesc="$pkgdesc - $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-_py2() {
- _py python2
- replaces="$pkgname"
-}
-
-_py3() {
- _py python3
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-
sha512sums="a3b7856aadc988fe153f5cf62552dd6219358f35ee2ca136e5eb5c9871cb7545986753af299e6b3e95877e9aa564559e95c548785f78e680766630b047a1ec89 greenlet-0.4.15.tar.gz
7dde3227207c3d637031c37f4ea2e81d454a3481164b58984528fa186e3edfa30d7f6075fef31c6b5f75c3b08129ec38ccc4d10c0c2cf3fb763803fc6dbd4643 ppc64le_clobbering.patch"